Πρόβλημα εγκατάστασης του hplip 3.16.11

...hardware-drivers για περιφερειακά (εκτυπωτές, κάμερες, εξ. σκληροί, κλπ)
Κανόνες Δ. Συζήτησης
Για την ευκολότερη επίλυση του προβλήματός σας.
Καλό είναι να δημοσιεύσετε τα αποτελέσματα της εντολής στο τερματικό :
lsusb

Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 12 Φεβ 2017, 02:41

Καλησπέρα. Η συζήτηση αφορά το πολυμηχάνημα hp deskjet 2130.

Ενώ κατέβασα, δε μπορώ να εγκαταστήσω το hplip-3.16.11, με αποτέλεσμα όταν πάω στο hp tools να περάσω το πολυμηχάνημα, δεν μου το αναγνωρίζει..



Στη συνέχεια μου βγάζει κι άλλες παρόμοιες αποτυχίες....

Θα ήθελα πρώτα να μου πει κάποιος πως να σβήσω από το φάκελο home το φάκελο που έφτιαξα στη προσπάθειά μου να εγκατατήσω το hplip (με το .run αρχείο) και μετά να μου προτείνει λύση.... θα μπορούσα να τον σβήσω και με ένα shift+del, αλλά υποθέτω πως δεν είναι ο σωστός τρόπος... :D

edit: έγινε αλλαγή της εικόνας σύμφωνα με τη πρόταση του the_eye.
Τελευταία επεξεργασία από chris1983 και 12 Φεβ 2017, 17:58, έχει επεξεργασθεί 1 φορά/ες συνολικά
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό the_eye » 12 Φεβ 2017, 17:46

Την εικόνα, ανεβασέ την εδώ, γιατί δεν φαίνεται http://imagebin.ubuntu-gr.org/

Μια χαρά τρόπος είναι το shift+del.
Θα σβήσεις τον φάκελο, αλλά όχι ότι ρυθμίσεις ή εγκαταστάσεις έχεις κάνε με τα προγράμμα που έτρεξες από αυτόν.
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.4.0-77-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 10785
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 12 Φεβ 2017, 18:01

Διόρθωσα την εικόνα στο πρώτο μου μήνυμα, ευχαριστώ. (είδα και ότι βρίσκεται πάνω πάνω στη σελίδα το "Imagebin" για μελλοντική χρήση)

Ωραία, πάω να σουτάρω και τον φάκελο.
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 23 Μαρ 2017, 12:32

Καμία ιδέα;
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό the_eye » 23 Μαρ 2017, 19:51

Την εγκατάσταση την τρέχεις με sudo ;
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.4.0-77-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 10785
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 24 Μαρ 2017, 10:52

Ακολουθώ τις οδηγίες από ---> http://hplipopensource.com/hplip-web/install/install/

Το μόνο που κάνω είναι να δώσω

Κώδικας: Επιλογή όλων
chris@toshiba:~$ sh hplip-3.16.11.run


και στη συνέχεια να συμφωνώ σε ό,τι λέει... εκτός από το σημείο που μου βγάζει πρόβλημα και πρέπει να αρνηθώ για να προχωρήσει!
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό the_eye » 24 Μαρ 2017, 18:32

Δώστο έτσι
Κώδικας: Επιλογή όλων
sudo hplip-3.16.11.run
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.4.0-77-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 10785
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 27 Μαρ 2017, 20:54

Έδωσα με το "sh" μαζί...
Κώδικας: Επιλογή όλων
sudo sh hplip-3.16.11.run

Στην αρχή με προέτρεψε να κάνω την εγκατάσταση ως απλός χρήστης και όχι root, αλλά εγώ συνέχισα... και βγάζει το ίδιο πρόβλημα με πριν...

Κώδικας: Επιλογή όλων
warning: hplip-install should not be run as root.

HP Linux Imaging and Printing System (ver. 3.16.11)
HPLIP Installer ver. 5.1

Copyright (c) 2001-15 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Mon-27-Mar-2017_20:57:32.log

/error: You are running the installer as root. It is highly recommended that you run the installer as
error: a regular (non-root) user. Do you still wish to continue?
Continue with installation (y=yes, n=no*, q=quit) ?




Και το πρόβλημα φαίνεται προς το τέλος...

Κώδικας: Επιλογή όλων
MISSING DEPENDENCIES
--------------------
Following dependencies are not installed. HPLIP will not work if all REQUIRED dependencies are not installed and some of the HPLIP features will not work if OPTIONAL dependencies are not installed.
Package-Name         Component            Required/Optional   
libcrypto            network              REQUIRED           
libnetsnmp-devel     network              REQUIRED           
sane-devel           scan                 REQUIRED           
gcc                  base                 REQUIRED           
cups-devel           base                 REQUIRED           
cups-image           base                 REQUIRED           
Do you want to install these missing dependencies (y=yes*, n=no, q=quit) ? y


INSTALL MISSING REQUIRED DEPENDENCIES
-------------------------------------
note: Installation of dependencies requires an active internet connection.
warning: Missing REQUIRED dependency: gcc (gcc - GNU Project C and C++ Compiler)
warning: Missing REQUIRED dependency: cups-devel (CUPS devel- Common Unix Printing System development files)
warning: Missing REQUIRED dependency: cups-image (CUPS image - CUPS image development files)
warning: Missing REQUIRED dependency: libcrypto (libcrypto - OpenSSL cryptographic library)
warning: Missing REQUIRED dependency: libnetsnmp-devel (libnetsnmp-devel - SNMP networking library development files)
warning: Missing REQUIRED dependency: sane-devel (SANE - Scanning library development files)


CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.


RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo apt-get update (Pre-depend step 3)
OK


DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
Running 'sudo apt-get install --assume-yes build-essential'
Please wait, this may take several minutes...
error: Command failed. Re-try #1...
Running 'sudo apt-get install --assume-yes build-essential'
Please wait, this may take several minutes...
error: Command failed. Re-try #2...
Running 'sudo apt-get install --assume-yes build-essential'
Please wait, this may take several minutes...
error: Command failed. Re-try #3...
Running 'sudo apt-get install --assume-yes build-essential'
Please wait, this may take several minutes...
error: Package install command failed with error code 100
Would you like to retry installing the missing package(s) (y=yes*, n=no, q=quit) ?


δίνω y και όλη την ώρα προσπαθεί, αλλά δεν μπορεί να εγκαταστήσει... :geek:
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό the_eye » 27 Μαρ 2017, 21:28

Γιατί δεν το βάζεις έτσι ;
Κώδικας: Επιλογή όλων
sudo apt-get install hplip
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.4.0-77-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 10785
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα εγκατάστασης του hplip 3.16.11

Δημοσίευσηαπό chris1983 » 27 Μαρ 2017, 23:04

Το έδωσα έτσι όπως ακριβώς γράφεις... έγινε μια χαρά η εγκατάσταση... πέρασα και το hpgui... και πάλι αρχίζουν τα προβλήματα... στο hpliptoolbox---> hp device manager--->setup device---> connection type: usb δεν το βλέπει!
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 14.04 trusty 3.19.0-61-generic 64bit (en_US.UTF-8, Unity ubuntu), Ubuntu 3.19.0-25-generic, Windows 7
3 Intel Core i5-3230M CPU @ 2.60GHz ‖ RAM 7859 MiB ‖ Intel VG10F - TOSHIBA SATELLITE L50-A-108
4 Intel 3rd Gen Core processor Graphics Controller [8086:0166] {i915} ⋮ nVidia GK208M [GeForce GT 740M] [10de:1292] {}
5 wlan0: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter [168c:0036] (rev 01) ⋮ eth0: Qualcomm Atheros QCA8171 Gigabit Ethernet [1969:10a1] (rev 10)
Άβαταρ μέλους
chris1983
babeTUX
babeTUX
 
Δημοσιεύσεις: 85
Εγγραφή: 02 Φεβ 2014, 03:13
Εκτύπωση

Επόμενο

  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Περιφερειακά

Μέλη σε σύνδεση

Μέλη σε αυτή τη Δ. Συζήτηση: Δεν υπάρχουν εγγεγραμμένα μέλη και 2 επισκέπτες