Οι clients δεν κάνουν shutdown

...ερωτήσεις & προβλήματα με τις εκπαιδευτικές εφαρμογές του ubuntu

Συντονιστής: ubuderix

Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό mpsal » 07 Νοέμ 2008, 15:16

Σας χαιρετώ
Είμαι καινούργιος στο forum αλλά στο λειτουργικό σύστημα Linux έχω προϋπηρεσία 4 έτη. Έχω εγκαταστήσει το ubuntu 8.04.1 LTSP. Όλα λειτούργησαν από την αρχή εκτός την ρύθμιση που έκανα για το πληκτρολόγιο που δεν κληρονομούσαν οι clients (από το forum). Οι clients είναι σχετικά παλιοί PII (233 - 350 MHz) οπότε απενεργοποίησα την κρυπτογράφηση των session και να κερδίσω σε ταχύτητα. Πρόσθεσα στο αρχείο /var/lib/tftpboot/lts/i386/ltp.conf την παράμετρο
LDM_DIRECTX=true
Επίσης χρησιμοποιώ UPS-MGE μοντέλο protection center 500. Τα UPS της MGE παρέχουν λογισμικό για τον έλεγχο του UPS (το UPS συνδέεται στην USB θύρα του server) και το λογισμικό εγκαθήσταται με την προσθήκη του ανάλογου αποθετηριού στο apt-synaptic. Επίσης το πολυμηχάνημα είναι της HP και λειτούργησε αμέσως μόλις το σύνδεσα στον server. Βέβαια εγκατέστησα και το HPLIP.
Ένα από τα προβλήματά μου είναι ότι κατά την εκκίνηση οι clients αναφέρουν ότι:
BIOS fails cutoff < 2000 acpi=force is required to enable acpi
Το αποτέλεσμα είναι ότι όταν κάνω shutdown τους clients αυτοί δεν κλείνουν αλλά παραμένει ανοιχτό το τροφοδοτικό (Θυμίζει το It's now safe to turn off your computer που είχαν τα windows 98). Θα πρέπει να κρατήσω παρατεταμένα το κουμπί του power ή να κλείσω το πολύμπριζο για να σβήσουν τελείως. Προφανώς πρέπει να περάσω την παράμετρο acpi=force σε κάποιο σημείο. Δοκίμασα στο τέλος του αρχείου /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default
στο οποίο αναφέρεται όμως το image που φορτώνουν οι clients αλλά χωρίς αποτέλεσμα. Μήπως λοιπόν γνωρίζετε σε ποιο αρχείο πρέπει να μπει η ρύθμιση αυτή; Πάντως με ένα laptop που συνδέθηκα στον server ο τερματισμός λειτουργεί κανονικά.
επίσης πως μπορεί να γίνει η αρχική σελίδα των clients στα Ελληνικά; Ενώ στον server εμφανίζει 'όνομα χρήστη, επιλογές' στους clients εμφανίζει 'user name, preferences'. Προφανώς έχει να κάνει με τον ldm, αλλά παρόλο που έψαξα στα forums δεν έβγαλα άκρη. Πάντως υπάρχει μετάφραση στα Ελληνικά.
Ευχαριστώ προκαταβολικά
mpsal
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 07 Νοέμ 2008, 14:35
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό ftso » 07 Νοέμ 2008, 16:18

Καλώς ήρθες :)

Δεν έχω ασχοληθεί με το θέμα και ούτε έχω την εμπειρία σου...
Αλλά αυτό που θα σου έλεγα περιγράφετε εδώ (https://help.ubuntu.com/community/BootOptions)
Ρίξε μια ματιά... :D
Άβαταρ μέλους
ftso
Επίτιμο μέλος
Επίτιμο μέλος
 
Δημοσιεύσεις: 6409
Εγγραφή: 12 Μάιος 2008, 13:40
Τοποθεσία: Αθήνα
IRC: ftso
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό kaingeo » 07 Νοέμ 2008, 19:35

Όλα λειτούργησαν από την αρχή εκτός την ρύθμιση που έκανα για το πληκτρολόγιο που δεν κληρονομούσαν οι clients (από το forum).


To bug αυτό έχει λυθεί και μου φαίνεται περίεργο. Το πληκτρολόγιο παίζει out of the box (κατευθείαν δηλαδή) χωρίς ρύθμιση.
Όσο για το άλλο δεν έχω ιδέα, και μάλλον πρέπει να ψάξεις πολύ.
kaingeo
punkTUX
punkTUX
 
Δημοσιεύσεις: 237
Εγγραφή: 10 Μάιος 2008, 21:15
Τοποθεσία: Ηράκλειο
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό alkisg » 09 Νοέμ 2008, 21:17

1. Για να περάσεις kernel parameter στους clients πρέπει να τη βάλεις στο /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default
Αυτό προϋποθέτει ότι ξεκινάνε με gpxe και όχι με etherboot, δες το θέμα με τη δισκέτα που έχω φτιάξει.
Αλλά πάντως και με τον γενικό να τους κλείνεις τους clients δεν είναι πρόβλημα, γιατί όταν είναι στην αρχική οθόνη τα πάντα είναι στη RAM, δεν γράφεται κάτι στο σκληρό.

2. Στην 8.10 η login screen των clients έχει ελληνικά out of the box, στην 8.04.1 αν και τα είχα μεταφράσει από καιρό, κάποια login scripts δεν εκτελούνται και έτσι ο ldm δεν φορτώνει ελληνικά ακόμα κι αν του βάλεις το ldm.mo. Για να το καταφέρεις λοιπόν θα πρέπει να δεις τις τελευταίες διορθώσεις που έκανε τέλη Οκτώβρη ο ogra στην intrepid και να τις κάνεις κι εσύ στην Hardy. :o
Ελπίζω να βγει κάποιο backport του νέου ldm και να γίνει αυτόματα (βέβαια το update του chroot γίνεται manually). Γι' αυτό πάντως προτείνω να γίνεται εγκατάσταση νέων εκδόσεων και όχι των LTS, οι εξελίξεις είναι πολύ γρήγορες για να μένουμε πίσω.

3. Για το πληκτρολόγιο, έπρεπε να είχες διαλέξει ελληνικά κατά την εκκίνηση του CD εγκατάστασης. Τώρα θα πρέπει να δώσεις
sudo dpkg-reconfigure console-setup
και στον server και στο chroot και να κάνεις ltsp-update-image.

4. Βάλε X_COLOR_DEPTH = 16 στο lts.conf, θα δεις αρκετά μεγάλη διαφορά στην ταχύτητα ανανέωσης της οθόνης των clients.

5. Δες εδώ για κάμποσα ακόμα: http://users.sch.gr/alkisg/tosteki/index.php?board=67.0

Με 'γεια το LTSP εργαστήριο!!!
alkisg
punkTUX
punkTUX
 
Δημοσιεύσεις: 190
Εγγραφή: 26 Μάιος 2008, 11:38
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό mpsal » 10 Νοέμ 2008, 11:04

Χαιρετώ. Νομίζω ότι σωστά είχα πάει στο συγγεκριμένο αρχείο /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default αλλά οι clients ξεκινούν με etherboot γι' αυτό και δεν δούλεψε. Θα δοκιμάσω με την δισκέτα που έχεις ετοιμάσει με gpxe και θα σου πω το αποτέλεσμα. Την παράμετρο X_COLOR_DEPTH = 16 την έχω περάσει στο αρχείο lts.conf αλλά προς το παρόν την έχω με σχόλιο. Μεγάλη διαφορά πάντως υπήρξε με το LDM_DIRECTX=True.Για το login screen των clients που δεν είναι στα ελληνικά δεν με απασχολεί ιδιαίτερα. Για το κλείσιμο από το γενικό γνωρίζω ότι δεν υπάρχει πρόβλημα αλλά οι χρήστες δεν το ξέρουν και τους βγάζουν από την πρίζα, οπότε θέλω την λύση του acpi=force. Στην εγκατάσταση είχα διαλέξει ελληνικά και έχω ελληνικά και στην κονσόλα. Όλα δηλαδή καλά. Ευχαριστώ και πάλι.
mpsal
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 07 Νοέμ 2008, 14:35
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό alkisg » 10 Νοέμ 2008, 12:58

mpsal έγραψε:Για το κλείσιμο από το γενικό γνωρίζω ότι δεν υπάρχει πρόβλημα αλλά οι χρήστες δεν το ξέρουν και τους βγάζουν από την πρίζα, οπότε θέλω την λύση του acpi=force.


Μπορούν να τους κλείνουν και με πατημένο το κουμπί για 5 δευτερόλεπτα.
Τα λέω αυτά γιατί σε 1 πιο παλιό PC που έχω στο εργαστήριο, δεν το έχω καταφέρει να κλείσει σωστά ακόμα και με acpi=force, ακόμα και με knoppel αντί για LTSP.
Δεν το παίδεψα και πολύ ώρα γιατί δεν με ένοιαζε, έχω πει στους μαθητές να μην κλείνουν τους Η/Υ και τους κλείνω εγώ από το γενικό. Αν το καταφέρεις πάντως κάνοντας κάτι διαφορετικό από το acpi=force, πες μας! :)
alkisg
punkTUX
punkTUX
 
Δημοσιεύσεις: 190
Εγγραφή: 26 Μάιος 2008, 11:38
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό mpsal » 19 Νοέμ 2008, 10:34

Σας χαιρετώ.
Παρόλο που δοκίμασα και με gpxe και έβαλα στο τέλος του αρχείου /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default το acpi=force, πάλι δεν έγινε τερματισμός. Δεν πειράζει θα ασχοληθώ ξανά κάποια άλλη φορά. Πάντως έχω την εντύπωση ότι με το gpxe αντί του etherboot ήταν κάπως πιο αργοί οι clients. Το αρχείο μου lts.conf περιέχει τις παραμέτρους:
LDM_DIRECTX=true
X_COLOR_DEPTH=16
X_VIDEORAM=4096
X_MODE_0=1024x768
X_HORZSYNC=30-70
X_VERTREFRESH=50-150
Δημιούργησα από το tarball το iso και την δισκέτα εκκίνησης του gpxe-0.9.5 που είναι η τελευταία σταθερή έκδοση. Δεν ξέρω πως να σας την κάνω διαθέσιμη αν φυσικά σας είναι χρήσιμη.
mpsal
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 07 Νοέμ 2008, 14:35
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό alkisg » 19 Νοέμ 2008, 11:04

Η δισκέτα και το .iso για την τελευταία έκδοση του gpxe υπάρχει στο site τους,
http://rom-o-matic.net/gpxe/gpxe-git/gp ... m-o-matic/
(για όλους τους οδηγούς είναι στη μέση της αναπτυσσόμενης λίστας, γράφει "gpxe:all-drivers"),

ενώ εδώ υπάρχει μια "πειραγμένη" έκδοση για σχολικά εργαστήρια ώστε να αρκεί ένας dhcp server (=του router) και να μην χρειάζεται και δεύτερος (= του ltsp server) ο οποίος πιθανώς να δημιουργεί προβλήματα.
alkisg
punkTUX
punkTUX
 
Δημοσιεύσεις: 190
Εγγραφή: 26 Μάιος 2008, 11:38
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό mpsal » 24 Νοέμ 2008, 17:39

Τελικά τα κατάφερα και σας γράφω πως μπορούν να τερματήσουν την λειτουργία τους οι thin clients σε παλιό hardware με BIOS πριν το 2000.
Στο αρχείο /var/lib/tftpboot/ltsp/i386/pxelinux.cfg/default έγραψα: DEFAULT vmlinuz ro initrd=initrd.img acpi=off apm=on apm=power_off quiet splash
Κατόπιν στο αρχείο /opt/ltsp/i386/etc/modules πρόσθεσα την παράμετρο: apm power_off=1
Φυσικά ακολουθεί η εντολή: sudo ltsp-update-image
Οι clients ξεκινουν με CD ή δισκέτα με την τελαιταία έκδοση του gpxe-git
Όταν λοιπόν στην οθόνη του ldm επιλέξει κάποιος Preferences και μετά Shutdown οι clients τερματίζουν κανονικά.
Χρησιμοποιώ το ubuntu hardy 8.04.1
Ευχαριστώ για την βοήθεια και περιμένω και τα δικά σας αποτελέσματα.
mpsal
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 07 Νοέμ 2008, 14:35
Εκτύπωση

Re: Οι clients δεν κάνουν shutdown

Δημοσίευσηαπό alkisg » 24 Νοέμ 2008, 20:57

mpsal έγραψε:Κατόπιν στο αρχείο /opt/ltsp/i386/etc/modules πρόσθεσα την παράμετρο: apm power_off=1
Φυσικά ακολουθεί η εντολή: sudo ltsp-update-image

Επομένως λογικά αντ' αυτού θα παίζει και με την προσθήκη της εντολής
Κώδικας: Επιλογή όλων
MODULE_01="apm power_off=1"
στο lts.conf, ώστε να μη χρειάζεται ltsp-update-image, αλλά κυρίως για να μη χρειάζεται να το θυμόμαστε σε κάθε distro upgrade (=ltsp-build-client).

Ευχαριστώ, θα το δοκιμάσω και θα ενημερώσω για το αν δουλεύει και στα δικά μου PC.
alkisg
punkTUX
punkTUX
 
Δημοσιεύσεις: 190
Εγγραφή: 26 Μάιος 2008, 11:38
Εκτύπωση

Επόμενο

Επιστροφή στο Εκπαιδευτικές εφαρμογές

Μέλη σε σύνδεση

Μέλη σε αυτή τη Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης