προβλημα με zte mf636 cosmote

...κάρτες δικτύου, modems, προβλήματα internet
Κανόνες Δ. Συζήτησης
Για την ευκολότερη επίλυση του προβλήματός σας.
Καλό είναι να δημοσιεύσετε τα αποτελέσματα των εντολών στο τερματικό :
lspci -nn
lsusb
rfkill list

προβλημα με zte mf636 cosmote

Δημοσίευσηαπό tsilikos » 16 Μάιος 2009, 16:17

Καραρχην με μεγαλο γεια σε ολουσ και συγχαριτιρια για την καλη δουλεια.Μολις σημερα εγινα μελοσ γιατι εγκατεστισα το ubuntu 9 και ειμαι ενθουσιασμενοσ.Ολα λειτοργισαν απσογα χωρισ drivers εκτοσ απο το usb τησ κοσμοτε.Θα ημοθν υποχρεοσ αμα μπορουσατε να με βοηθησετε
(κλασικα ειμαι ασχετοσ με λινουχ)οσο πιο λεπτομεριακα μπορειτε.Κοιταξα σχετικα θεματα αλλα δεν εβγαλα ακρη.Βασικα την συσκευη δεν μου την αναγνοριζει
καθολου
ευχαριστο εκ τον προτερων ΒΑΣΙΛΗΣ
tsilikos
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 16 Μάιος 2009, 16:05
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό linuxman » 16 Μάιος 2009, 18:53

Δες εδώ http://ktogias.wordpress.com/2008/11/10 ... buntu-810/ και εάν δεν βγάλεις άκρη τότε θα το δούμε .
Οδηγίες προς Νεοεισερχόμενους
1 Γνώσεις Linux: Πολύ καλό ┃ Προγραμματισμού: Ικανοποιητικό ┃ Αγγλικών: Ικανοποιητικό
2 Linux Mint 17.1 Rebecca 3.13.0-37-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
3 Intel Core i5-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
4 Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116] {i915}
5 wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34) ⋮ eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
http://www.greeklug.gr
Άβαταρ μέλους
linuxman
Επίτιμο μέλος
Επίτιμο μέλος
 
Δημοσιεύσεις: 10378
Εγγραφή: 10 Μάιος 2008, 20:41
Τοποθεσία: Thessaloniki / Macedonia / Greece
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό tsilikos » 16 Μάιος 2009, 19:06

1)Το προβλημα ειναι οτι με το που συνδεω το usb δεν γινεται τιποτα (δεν ανοιγει κανενα pop up)
2)η λυση αυτη ειναι για ubuntu 8.10 εγω εχω βαλει 9.04
3)η λυση αυτη δεν ειναι για το zte mf636 αλλα για το Huawei E172

παντος σε ευχαριστο πολυ για τον ενδιαφερον σου
πολυ φοβαμαι οτι δεν πρεπει να υπαρχει λυση για αυτο
με εκτιμιση ΒΑΣΙΛΗΣ
tsilikos
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 16 Μάιος 2009, 16:05
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό linuxman » 16 Μάιος 2009, 19:27

Πώς έκανες εγκατάσταση κανονική η μέσα από τα win ?
Έχεις κάνει ενημέρωση με ανοικτές πηγές λογισμικού .
Οδηγίες προς Νεοεισερχόμενους
1 Γνώσεις Linux: Πολύ καλό ┃ Προγραμματισμού: Ικανοποιητικό ┃ Αγγλικών: Ικανοποιητικό
2 Linux Mint 17.1 Rebecca 3.13.0-37-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
3 Intel Core i5-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
4 Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116] {i915}
5 wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34) ⋮ eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
http://www.greeklug.gr
Άβαταρ μέλους
linuxman
Επίτιμο μέλος
Επίτιμο μέλος
 
Δημοσιεύσεις: 10378
Εγγραφή: 10 Μάιος 2008, 20:41
Τοποθεσία: Thessaloniki / Macedonia / Greece
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό tsilikos » 16 Μάιος 2009, 19:44

τι ενοεις εγκατασταση ???απλα συνδεσα την συσκευη στο usb(δεν υπαρχουν drivers για αυτην την συσκευη σε ubuntu)
αν εννοεισ πος εγκατεστησα το ubuntu , το μηχανημα ειχε windows εβαλα το cd και εκανα boot τωρα εχει και τα 2 λειτουργικα
δεν μπορω να κανω ενημερωση γιατι ειμαι σε χωριο και εδω δεν εχουμε dsl γραμμες(παρεπιπτοντος δεν προκειτα να εχουμε ποτε,ψιφιακη ελλαδα σου λεει ο αλλος)οποτε μονο με αυτην την συσκευη μπορω να εχω προσβαση στο ιντερνετ
tsilikos
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 16 Μάιος 2009, 16:05
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό linuxman » 16 Μάιος 2009, 19:53

tsilikos έγραψε:τι ενοεις εγκατασταση ???απλα συνδεσα την συσκευη στο usb(δεν υπαρχουν drivers για αυτην την συσκευη σε ubuntu)
αν εννοεισ πος εγκατεστησα το ubuntu , το μηχανημα ειχε windows εβαλα το cd και εκανα boot τωρα εχει και τα 2 λειτουργικα
δεν μπορω να κανω ενημερωση γιατι ειμαι σε χωριο και εδω δεν εχουμε dsl γραμμες(παρεπιπτοντος δεν προκειτα να εχουμε ποτε,ψιφιακη ελλαδα σου λεει ο αλλος)οποτε μονο με αυτην την συσκευη μπορω να εχω προσβαση στο ιντερνετ

Αυτό λογικά είναι και το πρόβλημα , οπότε θα πρέπει να κάνεις έστω και μία βασική ενημέρωση .
Οδηγίες προς Νεοεισερχόμενους
1 Γνώσεις Linux: Πολύ καλό ┃ Προγραμματισμού: Ικανοποιητικό ┃ Αγγλικών: Ικανοποιητικό
2 Linux Mint 17.1 Rebecca 3.13.0-37-generic 64bit (el_GR.UTF-8, X-Cinnamon cinnamon)
3 Intel Core i5-2310M CPU @ 2.10GHz ‖ RAM 3866 MiB ‖ Dell Inc. 0D7C51 - Dell Inc. Dell System Vostro 3750
4 Intel 2nd Generation Core Processor Family Integrated Graphics [8086:0116] {i915}
5 wlan0: Intel Centrino Wireless-N 1030 [Rainbow Peak] [8086:008a] (rev 34) ⋮ eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
http://www.greeklug.gr
Άβαταρ μέλους
linuxman
Επίτιμο μέλος
Επίτιμο μέλος
 
Δημοσιεύσεις: 10378
Εγγραφή: 10 Μάιος 2008, 20:41
Τοποθεσία: Thessaloniki / Macedonia / Greece
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό GeorgeVita » 16 Μάιος 2009, 23:33

Γειά σας,
το 3G modem που δίνει τελευταία ο Cosmote είναι το ZTE MF636 το οποίο δεν αναγνωρίζεται απευθείας από κανένα version του Ubuntu (οταν είναι στην αρχική του κατάσταση).

Αυτό το modem έχει ρυθμιστεί να εκκινεί αυτόματα ένα "auto run εσωτερικό CD" (ZeroCD) εγκατάστασης που περιέχει τα windows drivers.

Από παράθυρο τερματικού (Applications > Accesories > Terminal) πληκτρολούμε: lsusb (και enter)
Ανάμεσα στις γραμμές που αναφέρονται όλα τα περιφερειακά usb είναι και το 19d2 : 2000 που αφορά το παραπάνω ZeroCD. Για να δουλέψει το MF636 πρέπει η κατάσταση αυτή να αλλαχθεί σε αυτή που αφορά το πραγματικό modem και δίνει 19d2 : 0031 στην εντολή lsusb (vendorID=19d2=ZTE και productID=0031=MF636? modem).

Για την παραπάνω ρύθμιση υπάρχουν τουλάχιστον 2 τρόποι που αναφέρονται στα: (παρακάτω), ενώ η linux λύση είναι με το usb_modeswitch (παρακάτω έχω την εύκολη λύση):
viewtopic.php?f=39&t=2874 και viewtopic.php?f=39&t=4905
και http://www.acomelectronics.com/GeorgeVi ... 36_el.html

Η "εύκολη" για μένα μέθοδος είναι το τρυκ με τα windows:
1. μεταγωγή του MF636 σε 19d2:0031 (1 φορά από περιβάλλον windows)

Για να γίνει η εσωτερική μεταγωγή στο modem και να εμφανιστεί ως 19d2:0031 στην εντολή lsusb, δίνουμε την εντολή AT+ZCDRUN=8 στο modem από περιβάλλον windows (μέσω hyperterminal ή άλλου προγράμματος σειριακής επικοινωνίας). Από το Control Panel των windows θα βρούμε την πόρτα (com7, com8, κλπ.) στην οποία έχει τοποθετηθεί το modem.

Εναλλακτικά κάνουμε το παρακάτω "τρυκ":
- από το control panel των vista προσθέτουμε την extra εντολή (στο init string) AT+ZCDRUN=8
- προσπαθούμε να συνδεθούμε μέσω της εφαρμογής που μας έδωσε ο πάροχος Mobile Broadband
- αφαιρούμε την παραπάνω εντολή (μέσω control panel)

ΣΗΜΑΝΤΙΚΗ ΣΗΜΕΙΩΣΗ: μετά την εκτέλεση της εντολής AT+ZCDRUN=8 μπορούμε να λειτουργήσουμε το modem στα windows και στο Ubuntu αλλά ΔΕΝ μπορούμε να εγκαταστήσουμε το modem σε άλλο windows PC! Για την επιστροφή στην αρχική κατάσταση πρέπει να δώσουμε την εντολή AT+ZCDRUN=9 με την παραπάνω διαδικασία.


Μετά κάνουμε έλεγχο με το lsusb ότι δίνει 19d2 : 0031 και συνεχίζουμε:
- Ανοίγουμε παράθυρο τερματικού και:
sudo gedit /usr/share/hal/fdi/information/10freedesktop/10-modem.fdi
Αναζήτηση (ctrl-F) γιά 19d2, πάμε μετά τη γραμμή "<!-- ZTE MF628 HSDPA USB dongle -->" και αλλάζουμε το "usb.product_id" από "0015" σε "0031"
- Save και Exit από το gedit
- Reboot με το MF636 τοποθετημένο στο USB port και απενεργοποίηση του Wireless (πάλι για ησυχία...)
- Κανονικά μετά την εκκίνηση θα ξεκινήσει μιά διαδικασία ρύθμισης της σύνδεσης "Mobile Broadband"
(αν δεν ξεκινήσει σε 30 δευτερόλεπτα δοκιμάστε με δεξί κλικ στο εικονίδιο του Network Manager και Edit Connections, Mobile Broadband, Add).
>>> Ρυθμίζουμε κάθε νέο δίκτυο με τα ίδια στοιχεία (στο δκό μου έγινε 2 φορές και εμφανίστηκαν 4 ίδια δίκτυα).

- Συνδεόμαστε με αριστερό κλικ στο εικονίδιο του Network Manager και μετά επιλογή στο ΤΕΛΕΥΤΑΙΟ από τα ΙΔΙΑ ΔΙΚΤΥΑ (πιθανόν να λειτουργεί και με κάπιο από τα παραπάνω αλλά ... οι δοκιμές δικές σας).


Τα παραπάνω έχουν λειτουργήσει με καθαρή εγκατάσταση 9.04 σε EeePC 1000H.

Φιλικά,
Γιώργος
Άβαταρ μέλους
GeorgeVita
babeTUX
babeTUX
 
Δημοσιεύσεις: 100
Εγγραφή: 26 Αύγ 2008, 14:33
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό tsilikos » 17 Μάιος 2009, 10:06

Αγαπητε φιλε Γιωργο σε ευχαριστω για την βοηθεια σου.Δεν εχω πολες γνωσεις στους υπολογιστεσς για αυτο δεν θα ακουλουθησω αυτο τον τροπο(φοβαμαι μην κανω καμια ζημια).Παντως η απαντηση σου ειναι πολυ κατατοπιστικη και ειμαι σιγουρος οτι θα βοηθησει καποιους αλλους με το ιδιο προβλημα.
Σε ευχαριστω για τον ενδιαφερον σου ΒΑΣΙΛΗΣ
tsilikos
babeTUX
babeTUX
 
Δημοσιεύσεις: 6
Εγγραφή: 16 Μάιος 2009, 16:05
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό GeorgeVita » 01 Ιούλ 2009, 19:23

Γειά σας,
μόλις εγκατέστησα Ubuntu 9.10 (με update 30/6/09) και kernel 2.6.30-10-generic

Εκανα δοκιμή με το 3G modem ZTE MF636 (που δίνει ο cosmote) και όλα πήγαν καλά.

Συγκεκριμένα:
Με την τοποθέτηση του modem στο USB port (χωρίς καμμία ειδική διαδικασία) στο lsusb αναφέρεται ως 19d2:2000
Εμφανίστηκε icon και παράθυρο με τα περιεχόμενα του εσωτερικού ZeroCD (που περιέχει τα win-drivers)
Το έκανα eject από το περιβάλλον desktop και μετά το lsusb έδειξε 19d2:0031 (τα στοιχεία του modem)
Ειχα προρυθμίσει στοιχεία για ένα provider αλλά εμφανίστηκαν δύο (ασήμαντο το λάθος)
Συνδέθηκα χρησιμοποιώντας το 2ο (δεν δοκίμασα το άλλο)

Συμπέρασμα: με το 9.10 το ZTE MF636 (αρκετά διαδεδομένο λόγω cosmote) ίσως να λειτουργεί χωρίς ρυθμίσεις, άρα είμαστε πιο κοντά στο Mobile Broadband Ubuntu-ing!

Φιλικά
Γιώργος

EDIT: νεώτερο update σε kernel 2.6.31-1-generic τα χάλασε όλα, οπότε περιμένουμε τα πιό "σταθερά" versions.
Άβαταρ μέλους
GeorgeVita
babeTUX
babeTUX
 
Δημοσιεύσεις: 100
Εγγραφή: 26 Αύγ 2008, 14:33
Εκτύπωση

Re: προβλημα με zte mf636 cosmote

Δημοσίευσηαπό ghppo » 24 Ιαν 2010, 03:52

Γειά σας
Είχα το ίδιο πρόβλημα με το ΖΤΕ 636 σε ubuntu remix 9.10 netbook asus eee 900.Δούλεψε κανονικά κάνοντας την διαδικασία που αναφέρει ο φίλος Γιώργος τον οποίο και ευχαριστούμε.
ghp
ghppo
babeTUX
babeTUX
 
Δημοσιεύσεις: 2
Εγγραφή: 27 Σεπ 2008, 17:00
Εκτύπωση

Επόμενο

  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Κάρτες Δικτύου (Ethernet, WiFi, Bluetooth) / Internet