χανεται ο grub μετά από καθε εκκίνηση των windows  Το θέμα επιλύθηκε

...εγκαταστάσεις, αναβαθμίσεις, διαχείριση partitions, boot-loader, κλπ

Συντονιστής: adem1

Κανόνες Δ. Συζήτησης
Στην ενότητα αυτή γράφουμε θέματα/ προβλήματα μόνο για το UBUNTU ή τα παράγωγά του.

χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό mangelasakis » 05 Σεπ 2014, 10:38

Γεια σας...

Έφτιαξα ένα καινούργιο pc του οποίου η μητρική έχει UEFI (το βραδάκι θα ενημερώσω την υπογραφή μου και θα σας πω πληροφορίες σχετικά με το pc γιατί τωρα βρίσκομαι στην δουλειά).

Εγκατέστησα τα windows 8.1 enteprise 64 bit και μετά τo ubuntu 14.04 amd64 σε UEFI mode και τα δύο και όλα καλά.
Κάθε φορά όμως που ξεκινώ τα windows χάνεται ο grub, οπότε δεν μπορώ να συνδεθώ στο ubuntu, με αποτέλεσμα να μπαίνω και να επαναφέρω τον grub από live usb αλλά κάθε φορά συμβαίνει το ίδιο. Τον grub τον επαναφέρω με το προγραμματάκι "Boot Repair".

Ευχαριστώ εκ των προτέρων...
Spoiler: show
Linux: 5ετής χρήση ┃ Προγραμ: μόνο C προς το παρών ┃ Αγγλικά: Μέτριος προς καλός
Desktop:
Ubuntu gnome 14.04 amd64 - Debian testing amd64
CPU: 4x AMD Phenom II X4 955 ‖ RAM 8000 MiB ‖ Gigabyte GA-MA785GT-UD3H
[Radeon HD 4200] Radeon HD 7750 ⎨1002:9710⎬
RTL8111/8168B PCI ⎨10ec:8168⎬ (rev 02)
Laptop:
Ubuntu gnome 14.04 amd64
4x Intel Core i3 M 330 2.13GHz ‖ RAM 3628 MiB ‖ Sony Corporation VPCEB1J1E
Intel VGA [8086:0046] (rev 02)
eth0: [11ab:4381] (rev 11) ⋮ wlan0: AR9285 [168c:002b] (rev 01)
mangelasakis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1149
Εγγραφή: 10 Μαρ 2009, 06:08
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό Learner » 05 Σεπ 2014, 18:13

Ωραίο πρόβλημα αυτό. Πρώτη φορά διαβάζω κάτι τέτοιο. Το μόνο που μου έρχεται στο μυαλό τώρα, είναι κάτι σχετικό με το fast boot. Για απενεργοποίησε το και δοκίμασε ξανά.
Διαφορετικά κάτι παίζει με το UEFI που πρέπει να βρούμε και να λύσουμε.
About Me
NickTux@GitHub

Spoiler: show
1. Ubuntu 18.04 LTS
2. Intel Core i3 CPU M 380 2.53GHz ‖ RAM 6GB ‖ Acer Aspire 5733
3. Intel Integrated Graphics [8086:0046] {i915}
4. wlan0: Atheros Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
Άβαταρ μέλους
Learner
Συντονιστής
Συντονιστής
 
Δημοσιεύσεις: 9753
Εγγραφή: 08 Νοέμ 2010, 21:24
Τοποθεσία: Αθήνα
Launchpad: nicktux
IRC: NickTux
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό the_eye » 05 Σεπ 2014, 23:02

Έχεις κάποιο λογισμικό εγκατεστημένο στα win για προστασία δίσκου ; πχ deep freeze
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 18.04 bionic 4.15.0-42-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 11451
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό mangelasakis » 05 Σεπ 2014, 23:30

μάλλον έχω το εξής πρόβλημα http://askubuntu.com/questions/447201/windows-8-deletes-grub-when-booting

το fastboot είναι απενεργοποιημένο από default.
Spoiler: show
Linux: 5ετής χρήση ┃ Προγραμ: μόνο C προς το παρών ┃ Αγγλικά: Μέτριος προς καλός
Desktop:
Ubuntu gnome 14.04 amd64 - Debian testing amd64
CPU: 4x AMD Phenom II X4 955 ‖ RAM 8000 MiB ‖ Gigabyte GA-MA785GT-UD3H
[Radeon HD 4200] Radeon HD 7750 ⎨1002:9710⎬
RTL8111/8168B PCI ⎨10ec:8168⎬ (rev 02)
Laptop:
Ubuntu gnome 14.04 amd64
4x Intel Core i3 M 330 2.13GHz ‖ RAM 3628 MiB ‖ Sony Corporation VPCEB1J1E
Intel VGA [8086:0046] (rev 02)
eth0: [11ab:4381] (rev 11) ⋮ wlan0: AR9285 [168c:002b] (rev 01)
mangelasakis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1149
Εγγραφή: 10 Μαρ 2009, 06:08
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows  Το θέμα επιλύθηκε

Δημοσίευσηαπό dim459 » 06 Σεπ 2014, 02:48

http://forum.ubuntu-gr.org/viewtopic.php?f=9&t=29669&p=314226&hilit=%CE%B5%CF%80%CE%B1%CE%BD%CE%B1%CF%86%CE%BF%CF%81%CE%AC+grub+%CE%B1%CF%80%CF%8C+windows#p314226
Μέχρι να βγάλεις άκρη δες παραπάνω πως επαναφέρουν τον grub μέσα από τα windows, για να μην τρέχεις κάθε φορά το boot repair από live.
Γνώσεις ⇛ Linux: Αν μου δώσεις οδηγίες σε τερματικό δεν τρομάζω ┃ Προγραμματισμός: Καθόλου┃ Αγγλικά: Εξαιρετικά
Λειτουργικό : Kubuntu 18.04 64bit.
Συσκευές-> Πάρα πολλές, θα στο γράψω ανά περίπτωση.
Άβαταρ μέλους
dim459
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 3710
Εγγραφή: 15 Φεβ 2009, 19:28
Τοποθεσία: Bόρεια Αττική
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό mangelasakis » 06 Σεπ 2014, 09:34

Η λύση δόθηκε από τον dim459 τον οποίο και ευχαριστώ πολύ.

Αυτό που έκανα είναι το εξής:

Σύμφωνα με το παραπάνω link που μου έστειλε ο dim459, απενεργοποίησα το secure boot μέσα από τα windows8.1 (προσοχή εδώ από ότι διαπίστωσα υπάρχει secure boot και μέσα από το UEFI αλλά και μέσα από τα windows8.1 , αυτή την στιγμη είναι και τα δύο απενεργοποιημένα. Θα δοκιμάσω και με ενεργοποιημένο το secure boot από το UEFI να δώ αν θα δουλέψει) επανέφερα και τον grub με την εντολή από το windows command line και το πρόβλημα διορθώθηκε....

Ευχαριστώ και πάλι για την βοήθεια...
Spoiler: show
Linux: 5ετής χρήση ┃ Προγραμ: μόνο C προς το παρών ┃ Αγγλικά: Μέτριος προς καλός
Desktop:
Ubuntu gnome 14.04 amd64 - Debian testing amd64
CPU: 4x AMD Phenom II X4 955 ‖ RAM 8000 MiB ‖ Gigabyte GA-MA785GT-UD3H
[Radeon HD 4200] Radeon HD 7750 ⎨1002:9710⎬
RTL8111/8168B PCI ⎨10ec:8168⎬ (rev 02)
Laptop:
Ubuntu gnome 14.04 amd64
4x Intel Core i3 M 330 2.13GHz ‖ RAM 3628 MiB ‖ Sony Corporation VPCEB1J1E
Intel VGA [8086:0046] (rev 02)
eth0: [11ab:4381] (rev 11) ⋮ wlan0: AR9285 [168c:002b] (rev 01)
mangelasakis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1149
Εγγραφή: 10 Μαρ 2009, 06:08
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό dim459 » 06 Σεπ 2014, 12:32

H αλήθεια είναι ότι δεν ξέρω αν το θέμα επιλύεται μόνιμα κατ' αυτόν τον τρόπο (αν και από τότε που τα απενεργοποίησα όπως παραπάνω δεν μου ξαναπείραξε τον grub, όμως μπουτάρει σπάνια windows).
Βασικά το πόσταρα για να επαναφέρεις τον grub μέσα από τα windows αν στο ξανακάνει, διότι είναι σπαστικό να κάνεις επανεκκίνηση με live και να ακολουθείς όλη τη διαδικασία του boot repair για να τρέξεις ubuntu.
Γνώσεις ⇛ Linux: Αν μου δώσεις οδηγίες σε τερματικό δεν τρομάζω ┃ Προγραμματισμός: Καθόλου┃ Αγγλικά: Εξαιρετικά
Λειτουργικό : Kubuntu 18.04 64bit.
Συσκευές-> Πάρα πολλές, θα στο γράψω ανά περίπτωση.
Άβαταρ μέλους
dim459
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 3710
Εγγραφή: 15 Φεβ 2009, 19:28
Τοποθεσία: Bόρεια Αττική
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό George Pantelis » 06 Σεπ 2014, 13:47

Τσεκάρισε όμως την απάντηση που έδωσε την λύση στο πρόβλημα ώστε να είναι εύκολη η εύρεσή της από όποιον θα βρεί το ίδιο πρόβλημα μελλοντικά. Εκεί που είναι το τσεκ τώρα δεν βοηθάει. :clap:
1 Γνώσεις Linux: Μέτριες ┃ Προγραμματισμού: Οχι ┃ Αγγλικών: Αριστο
2 EndeavourOS KDE plasma / Gnome, Ubuntu 19.10 5.3.0-18-generic 64bit (el_GR.UTF-8,Gnome ubuntu), Arch linux (VM)
3 Intel Core2 Duo CPU P8400 2.26GHz ‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
4 Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915
5 eth0: Intel 82567LM Gigabit Network Connection [8086:10f5] (rev 03) ⋮ wlan0: Intel WiFi Link 5100 [8086:4232]
Άβαταρ μέλους
George Pantelis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 975
Εγγραφή: 23 Νοέμ 2013, 19:24
Τοποθεσία: Xαλκίδα
Launchpad: George Pantelis
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό mangelasakis » 07 Σεπ 2014, 15:05

George Pantelis έγραψε:Τσεκάρισε όμως την απάντηση που έδωσε την λύση στο πρόβλημα ώστε να είναι εύκολη η εύρεσή της από όποιον θα βρεί το ίδιο πρόβλημα μελλοντικά. Εκεί που είναι το τσεκ τώρα δεν βοηθάει. :clap:

Α δεν το ήξερα αυτό το κολπάκι. Συγνώμη.... Το διόρθωσα τώρα...

dim459 έγραψε:H αλήθεια είναι ότι δεν ξέρω αν το θέμα επιλύεται μόνιμα κατ' αυτόν τον τρόπο (αν και από τότε που τα απενεργοποίησα όπως παραπάνω δεν μου ξαναπείραξε τον grub, όμως μπουτάρει σπάνια windows).
Βασικά το πόσταρα για να επαναφέρεις τον grub μέσα από τα windows αν στο ξανακάνει, διότι είναι σπαστικό να κάνεις επανεκκίνηση με live και να ακολουθείς όλη τη διαδικασία του boot repair για να τρέξεις ubuntu.

Προς το παρών πάντως όλα μου δουλεύουν ρολόι. Δεν έχω κανένα θέμα με το boot στα windows. Βέβαια είναι αρκετά νωρίς ακόμη αλλά 6-7 φορές που έχω μπουτάρει τα παραθύρια δεν μου έχει δημιουργήσει κάποιο θέμα. Απενεργοποίησα και hibernate των windows για να μπορώ να διαβάζω το partition τους από το ubuntu και τώρα όλα καλά...
Spoiler: show
Linux: 5ετής χρήση ┃ Προγραμ: μόνο C προς το παρών ┃ Αγγλικά: Μέτριος προς καλός
Desktop:
Ubuntu gnome 14.04 amd64 - Debian testing amd64
CPU: 4x AMD Phenom II X4 955 ‖ RAM 8000 MiB ‖ Gigabyte GA-MA785GT-UD3H
[Radeon HD 4200] Radeon HD 7750 ⎨1002:9710⎬
RTL8111/8168B PCI ⎨10ec:8168⎬ (rev 02)
Laptop:
Ubuntu gnome 14.04 amd64
4x Intel Core i3 M 330 2.13GHz ‖ RAM 3628 MiB ‖ Sony Corporation VPCEB1J1E
Intel VGA [8086:0046] (rev 02)
eth0: [11ab:4381] (rev 11) ⋮ wlan0: AR9285 [168c:002b] (rev 01)
mangelasakis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1149
Εγγραφή: 10 Μαρ 2009, 06:08
Εκτύπωση

Re: χανεται ο grub μετά από καθε εκκίνηση των windows

Δημοσίευσηαπό dim459 » 07 Σεπ 2014, 18:39

mangelasakis έγραψε:Απενεργοποίησα και hibernate των windows για να μπορώ να διαβάζω το partition τους από το ubuntu και τώρα όλα καλά...

Εντάξει εξαρτάται από τη συχνότητα που τα χρησιμοποιείς και από τη συχνότητα που χρειάζεσαι πρόσβαση στο partition τους μέσα από linux. Επιβραδύνει αρκετά το μπουτάρισμά τους, οπότε αν η πρώτη είναι μεγάλη και η δεύτερη μικρή, μπορεί και να μην συμφέρει. Εγώ ας πούμε που από τον Ιανουάριο τα έχω μπουτάρει συνολικά 5-6 φορές, προφανώς το έχω απενεργοποιημένο.
Γνώσεις ⇛ Linux: Αν μου δώσεις οδηγίες σε τερματικό δεν τρομάζω ┃ Προγραμματισμός: Καθόλου┃ Αγγλικά: Εξαιρετικά
Λειτουργικό : Kubuntu 18.04 64bit.
Συσκευές-> Πάρα πολλές, θα στο γράψω ανά περίπτωση.
Άβαταρ μέλους
dim459
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 3710
Εγγραφή: 15 Φεβ 2009, 19:28
Τοποθεσία: Bόρεια Αττική
Εκτύπωση


  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Λειτουργικό Σύστημα