προβλημα με fonts απο yahoo mail σε thunderbird  Το θέμα επιλύθηκε

...ρύθμιση - εγκατάσταση web server, mail server, ftp server, κλπ

Συντονιστές: the_eye, konnn

προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό kwstas8es » 24 Μάιος 2019, 19:39

καλησπερα,

στα μηνυματα που στελνω απο yahoo smtp μεσω Τhunderbird οι ελληνικοι χαρακτηρες εμφανιζονται με αυτο τον τροπο "??????" !
αν χρησιμοποιησω τον google smtp ειναι ολα ενταξει!

μπορει να με βοηθησει καποιος αν γνωριζει σας παρακαλω?

ubuntu 16.04 LTS
kwstas8es
babeTUX
babeTUX
 
Δημοσιεύσεις: 36
Εγγραφή: 13 Ιούλ 2009, 15:52
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό Tassos10 » 25 Ιούλ 2019, 10:00

Χαίρεται @kwstas8es,

Βλέπω λοιπόν πως έχει και άλλος το ίδιο πρόβλημα με εμένα.

Εσύ ποια έκδοση του Thunderbird ( thunderbird --version ) έχεις ;
Διότι και εγώ έχω αυτό το πρόβλημα σε Thunderbird 60.3.0 (Debian GNU/Linux 8.11 (jessie) ) και Thunderbird 60.8.0 ( Debian GNU/Linux 9.9 (stretch) ).
Όταν λες :
kwstas8es έγραψε:αν χρησιμοποιησω τον google smtp ειναι ολα ενταξει!

Τι ακριβώς εννοείς ;


Προσωπικά έχω δύο λογαριασμούς e-mail ( επαγγελματικό - gandi.net και το 1ο προσωπικό μου e-mail στο yahoo ) και τους έχω προσθέσει και τους δύο στον Thunderbird e-mail client. Εγώ έχω κάνει λοιπόν τις εξής παρατηρήσεις :

  • Το πρόβλημα παρουσιάζεται όταν στέλνω μηνύματα από το Yahoo account σε άλλους, με ελληνικούς χαρακτήρες ( οι αγγλικοί χαρακτήρες δεν έχουν πρόβλημα ). Τότε, οι άλλοι βλέπουν στην θέση των ελληνικών χαρακτήρων, ερωτηματικά ( "?" ).

  • Αν στείλω το μήνυμα ψηφιακά υπογεγραμμένο ( enigmail ) ή κρυπτογραφημένο, τότε στον παραλήπτη φτάνει χωρίς πρόβλημα. Φαίνονται κανονικά και οι ελληνικοί χαρακτήρες.
    Ναι, ακόμη και με απλή ψηφιακή υπογραφή ( που ο παραλήπτης μπορεί να διαβάσει το μήνυμα κατευθείαν - απλώς βλέπει επισυναπτόμενη την υπογραφή μου ), το παραλαμβάνει χωρίς κανένα απολύτως πρόβλημα!

  • Αν στείλω ένα μήνυμα με ελληνικούς χαρακτήρες χωρίς να το υπογράψω ψηφιακά (προσωρινή μου λύση), τότε ο παραλήπτης ναι μεν το λαμβάνει με ερωτηματικά, αλλά, αν μπω μέσω browser στο mail.yahoo.com και ανοίξω το μήνυμα που έστειλα από τον Thunderbird, εγώ το διαβάζω κανονικά! - Άσχετα που στον αποστολέα φτάνει με ερωτηματικά -. Από το web panel της Yahoo, εμένα μου εμφανίζει κανονικότατα και τους ελληνικούς χαρακτήρες!
    Και το τρελό εδώ είναι, πως αν πατήσω απλώς να ξανά στείλω το μήνυμα (μέσω του web panel της Yahoo), τότε αυτό θα φτάσει στον παραλήπτη χωρίς κανένα πρόβλημα.
    Επίσης, τα μηνύματα αυτά που στέλνω στους άλλους με ελληνικούς χαρακτήρες και φτάνουν με ερωτηματικά στην θέση τους, από τον e-mail client του κινητού μου τα βλέπω μια χαρά! Μου εμφανίζονται σωστά οι ελληνικοί χαρακτήρες! Και επίσης αν πατήσω επαναποστολή του μηνύματος από τον e-mail client του κινητού μου, τότε το μήνυμα θα φτάσει στον παραλήπτη χωρίς κανένα πρόβλημα.

  • Αν στείλω μήνυμα από τον λογαριασμό μου στο gandi.net, τότε δεν υπάρχει κανένα απολύτως πρόβλημα! Είτε ελληνικά, είτε κινέζικα στείλω, ο παραλήπτης το λαμβάνει χωρίς κανένα πρόβλημα.

Και εγώ υπέθετα αρχικά πως ίσος ήταν πρόβλημα των γραμματοσειρών, αλλά μετά από τα παραπάνω, δεν νομίζω να φταίει η γραμματοσειρά.
Εσύ τι δοκιμές έχεις κάνει ;

Γιατί τελευταία αυτή η Yahoo μας παιδεύει ; :mrgreen:
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Πρώτα βήματα ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 12.04 precise 3.2.0-50-generic 64bit (el_GR.UTF-8, Unity ubuntu), Ubuntu 3.2.0-49-generic
3 Intel Core2 Quad CPU Q9400 2.66GHz ‖ RAM 3954 MiB ‖ ASRock G31M-S
4 nVidia G92 [GeForce 9800 GT] [10de:0614] {nvidia}
5 eth0: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Tassos10
dudeTUX
dudeTUX
 
Δημοσιεύσεις: 459
Εγγραφή: 29 Μαρ 2010, 10:43
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird  Το θέμα επιλύθηκε

Δημοσίευσηαπό kwstas8es » 25 Ιούλ 2019, 11:36

καλημέρα!
ειχα σχεδον ξεχασει αυτη τη δημοσιευση!
για να το λυσω προσωρινα ειχα απλα αλλαξει τον διακομιστη εξερχομενων(smtp απο τις "ρυθμισεις λογαριασμου") σε αυτον του gmail(ειναι δευτερος λογαριασμος μου στο thunderbird (60.80.0 64-bit) που δεν παρουσιαζει το ιδιο προβλημα.
τωρα με την ευκαιρια ειπα να το ξαναδω μηπως εχει αλλαξει κατι και οντως πλεον δεν εχω το ιδιο προβλημα! δοκιμασα να δω αν παραμενει με επανεκινηση του thundrbird και ολα καλα! δεν δοκιμασα μονο επανεκκινηση του υπολογιστη...

το προβλημα παρουσιαζοταν μονο σε μηνύματα με ελληνικους χαρακτηρες απο λογαριασμο yahoo συνδεδεμενο στο thunderbird και με διακομιστη εξερχομενων(smtp) του yahoo.

ουτε θυμαμαι ποσα ειχα δοκιμασει... αλλαγες στο thunderbird κυριως
kwstas8es
babeTUX
babeTUX
 
Δημοσιεύσεις: 36
Εγγραφή: 13 Ιούλ 2009, 15:52
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό Tassos10 » 25 Ιούλ 2019, 18:33

kwstas8es έγραψε:για να το λυσω προσωρινα ειχα απλα αλλαξει τον διακομιστη εξερχομενων(smtp απο τις "ρυθμισεις λογαριασμου") σε αυτον του gmail(ειναι δευτερος λογαριασμος μου στο thunderbird (60.80.0 64-bit) που δεν παρουσιαζει το ιδιο προβλημα.

kwstas8es έγραψε:το προβλημα παρουσιαζοταν μονο σε μηνύματα με ελληνικους χαρακτηρες απο λογαριασμο yahoo συνδεδεμενο στο thunderbird και με διακομιστη εξερχομενων(smtp) του yahoo.

Συγνώμη για να καταλάβω, δεν άφησες το Yahoo e-mail account σου, απλώς πήγες στις ρυθμίσεις του, και έβαλες να χρησιμοποιεί τον SMTP της Google που έχει για το Gmail ;
Δηλαδή από εδώ πέρα ;

άλλαξες από εδώ τον server ;
πείραξες και από εδώ κάτι μήπως ;


Με συγχωρείς, αλλά μου φαίνεται λίγο περίεργο και δεν ήξερα πως γίνεται κάτι τέτοιο για αυτό και το ρωτάω.

kwstas8es έγραψε:τωρα με την ευκαιρια ειπα να το ξαναδω μηπως εχει αλλαξει κατι και οντως πλεον δεν εχω το ιδιο προβλημα! δοκιμασα να δω αν παραμενει με επανεκινηση του thundrbird και ολα καλα! δεν δοκιμασα μονο επανεκκινηση του υπολογιστη...

Πλέον επανέφερες τα πάντα στις προεπιλεγμένες ( default ) ρυθμίσεις και σε εσένα τα μηνύματα με ελληνικούς χαρακτήρες φτάνουν σωστά στους παραλήπτες τους ;
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Πρώτα βήματα ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 12.04 precise 3.2.0-50-generic 64bit (el_GR.UTF-8, Unity ubuntu), Ubuntu 3.2.0-49-generic
3 Intel Core2 Quad CPU Q9400 2.66GHz ‖ RAM 3954 MiB ‖ ASRock G31M-S
4 nVidia G92 [GeForce 9800 GT] [10de:0614] {nvidia}
5 eth0: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Tassos10
dudeTUX
dudeTUX
 
Δημοσιεύσεις: 459
Εγγραφή: 29 Μαρ 2010, 10:43
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό kwstas8es » 25 Ιούλ 2019, 19:01

στην πρωτη σου φωτο αριστερα απο το βελακι σου, απλα επελεξε αλλον διακομιστη απο τη λιστα! δεν αλλαξα κατι στο "edit smtp server". τα υπολοιπα τα εχουμε ιδια.
το μονο που αλλαξα σημερα ηταν να βαλω παλι το default smtp server του yahoo mail

[img]
[/img] [img]
[/img] [img]
[/img] [img]
[/img]
kwstas8es
babeTUX
babeTUX
 
Δημοσιεύσεις: 36
Εγγραφή: 13 Ιούλ 2009, 15:52
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό Tassos10 » 26 Ιούλ 2019, 09:42

kwstas8es έγραψε:στην πρωτη σου φωτο αριστερα απο το βελακι σου, απλα επελεξε αλλον διακομιστη απο τη λιστα! δεν αλλαξα κατι στο "edit smtp server". τα υπολοιπα τα εχουμε ιδια.
το μονο που αλλαξα σημερα ηταν να βαλω παλι το default smtp server του yahoo mail



Μάλιστα, κατάλαβα. Ενδιαφέρον αυτό! Πολύ ενδιαφέρον η προσωρινή σου λύση! Δεν ήξερα πως για τα απεσταλμένα μπορείς να χρησιμοποιήσεις και άλλων διακομιστή πέραν αυτού που σου παρέχει ο εκάστοτε πάροχος του λογαριασμού του ηλεκτρονικού ταχυδρομείου σου.

Μάλλον και εσύ στο Thunderbird είχες προσθέσει δύο λογαριασμούς e-mail, ένας της Yahoo! και ένας της Google για αυτό και σου βγάζει ως δεύτερη επιλογή της Google. Εγώ που έχω ένα λογαριασμό από το Gandi.net και ένα από το Yahoo!, εκεί μου βγάζει ως δεύτερη επιλογή τον SMTP outgoing server της Gandi.net.


Το επίσης ενδιαφέρον που αναφέρεις, είναι πως γυρνώντας στον SMTP outgoing server της Yahoo!, πλέον σε εσένα φαίνεται να έχει διορθωθεί το πρόβλημα! Είσαι σίγουρος ; Γιατί εγώ συνεχίζω να το έχω.

Πάντως διαβάζοντας στο Bugzilla bug (1568412), όπως αναφέρουν, το πρόβλημα υπάρχει εδώ και πολύ καιρό και ευθύνεται για αυτό η ίδια η Yahoo!.
Η κύρια προσωρινή λύση που προτείνουν είναι να πας στο μενού του Thunderbird (δεξιά ) -> Preferences -> Preferences -> Advanced και να πατήσεις "Config Editor...". Να αναζητήσεις με "strictly_mime" και να βρεις την επιλογή "mail.strictly_mime" και να το κάνεις "true".

Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Πρώτα βήματα ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 12.04 precise 3.2.0-50-generic 64bit (el_GR.UTF-8, Unity ubuntu), Ubuntu 3.2.0-49-generic
3 Intel Core2 Quad CPU Q9400 2.66GHz ‖ RAM 3954 MiB ‖ ASRock G31M-S
4 nVidia G92 [GeForce 9800 GT] [10de:0614] {nvidia}
5 eth0: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Tassos10
dudeTUX
dudeTUX
 
Δημοσιεύσεις: 459
Εγγραφή: 29 Μαρ 2010, 10:43
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό kwstas8es » 26 Ιούλ 2019, 10:18

καλημερα!
με τον τροπο αυτο σου λυθηκε? σ'εμενα ειναι default "false" και σημερα μετα απο επανεκκίνηση εξακολουθει να δουλευει μια χαρα! πιθανώς διορθωθηκε με καποια τελευταια ενημερωση...
kwstas8es
babeTUX
babeTUX
 
Δημοσιεύσεις: 36
Εγγραφή: 13 Ιούλ 2009, 15:52
Εκτύπωση

Re: προβλημα με fonts απο yahoo mail σε thunderbird

Δημοσίευσηαπό Tassos10 » 26 Ιούλ 2019, 10:37

Ναι, σε εμένα έτσι λύθηκε. Όπως αναφέρουν αυτοί θέτοντας το "mail.strictly_mime" σε "true" το πρόβλημα λύθηκε και σε εμένα ( μόλις το δοκίμασα ).

Την δική σου μέθοδο για να είμαι ειλικρινής δεν πρόλαβα να την δοκιμάσω διότι διορθώθηκε αμέσως με τον παραπάνω τρόπο.

Μου κάνει εντύπωση πάντως πως σε εσένα με Thunderbird 60.8.0 ( έχεις σίγουρα αυτή την έκδοση ; ) με την παραπάνω ρύθμιση στο false που λειτουργεί σωστά.
Άστο έτσι και το βλέπουμε στο μέλλον αν σου ξανά δημιουργήσει πρόβλημα.


Off topic:
Στην απάντηση που δίνει την λύση στο πρόβλημα σου, πάτα το πράσινο "τικ" ώστε να φαίνεται σαν λυμένο το θέμα και ο επόμενος αναγνώστης να ξέρει αμέσως ποια απάντηση δίνει την λύση.
Spoiler: show
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Πρώτα βήματα ┃ Αγγλικών: Ικανοποιητικό
2 Ubuntu 12.04 precise 3.2.0-50-generic 64bit (el_GR.UTF-8, Unity ubuntu), Ubuntu 3.2.0-49-generic
3 Intel Core2 Quad CPU Q9400 2.66GHz ‖ RAM 3954 MiB ‖ ASRock G31M-S
4 nVidia G92 [GeForce 9800 GT] [10de:0614] {nvidia}
5 eth0: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller [10ec:8136] (rev 02)
Tassos10
dudeTUX
dudeTUX
 
Δημοσιεύσεις: 459
Εγγραφή: 29 Μαρ 2010, 10:43
Εκτύπωση


  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Διακομιστές / Εξυπηρετητές

cron