Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

...το μέρος για να ξεκινήσετε!

Συντονιστής: adem1

Κανόνες Δ. Συζήτησης
Παρακαλώ να επιλέξετε, με προσοχή, την άδεια που θέλετε να έχουν οι οδηγοί που συγγράφετε.
Πληροφορίες για τις άδειες μπορείτε να βρείτε εδώ.
Άμα επιθυμείτε κάποια άλλη άδεια επικοινωνήστε με κάποιο Διαχειριστή είτε Συντονιστή.

Σημαντικό είναι να χρησιμοποιήσετε την υπηρεσία http://imagebin.ubuntu-gr.org για τις εικόνες.

Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό vagrale13 » 15 Μαρ 2011, 21:40

Παρακατω, θα δουμε τον τροπο εγκαταστασης της τελευταιας εκδοσης του FFmpeg και του x264
Με τον παρακατω τροπο θα δημιουργηθουν πακετα .deb, οποτε αν καποιος εχει 2 ή και περισσοτερους Η/Υ με το ιδιο συστημα, μπορει απλα να εγκαταστησει τα πακετα! :)
Περισσοτερα για τους codec μπορουμε να δουμε εδω Εγκατάσταση codec και πολυμέσων
και για τη χρηση του εδω Διεργασίες σε αρχεία βίντεο και ήχου με πολλαπλά εργαλεία
Πηγη οδηγου http://ubuntuforums.org/showthread.php?t=786095

Εικόνα


Καλο ειναι, να μην δοκιμασουμε τα παρακατω,
αν δεν γνωριζουμε το λογο που θα το κανουμε αυτο!


Αν εχουμε καποιο error σε καποια απο τις παρακατω εντολες, δεν συνεχιζουμε,
ποσταρουμε το περιεχομενου του τερματικου.



Τελευταιες 3 αλλαγες του οδηγου

10-05-2014 => Αλλαγη στην εντολη εγκαταστασης για το libvpx. Προσθηκη συνδεσμων για παραδειγματα κωδικοποιησης.
11-04-2014 => Αλλαγη στις εντολες εγκαταστασης για τα ffmpeg και libx264.
10-04-2014 => Αλλαγη του οδηγου. (Οι χρηστες που εχουν κανει τη διαδικασια νωριτερα απο αυτη την ημ/νια, πρεπει να κανουν τη διαδικασια εγκαταστασης απο την αρχη )


> Για τις εκδοσεις Ubuntu 12.04 (και νεοτερες) <



Εγκατασταση FFmpeg και x264

Πρεπει πρωτα να κανουμε απεγκατασταση καποια πακετα, οποτε εκτελουμε

Σημειωση: Στην παρακατω εντολη, ισως μας ζητηθει να αφαιρεθουν καποια πακετα αν ειναι εγκατεστημενα οπως kdenlive, devede, winff, κλπ. Αν θελουμε να συνεχισουμε την αναβαθμιση της τελευταιας εκδοσης FFmpeg και x264 θα πρεπει να συμφωνησουμε να αφαιρεθουν τα πακετα, και στο τελος της διαδικασιας να τα ξανα εγκαταστησουμε.

Κώδικας: Επιλογή όλων
sudo apt-get remove ffmpeg x264 libav-tools libvpx libvpx-dev libx264-dev yasm

μετα εκτελουμε τις δυο εντολες
Κώδικας: Επιλογή όλων
sudo apt-get update

Κώδικας: Επιλογή όλων
sudo apt-get -y install autoconf build-essential checkinstall git libfaac-dev libgpac-dev \
  libjack-jackd2-dev libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev \
  librtmp-dev libsdl1.2-dev libtheora-dev libtool libva-dev libvdpau-dev libvorbis-dev \
  libx11-dev libxext-dev libxfixes-dev pkg-config texi2html yasm zlib1g-dev

μετα δημιουργουμε ενα φακελο στο home μας, για να εχουμε ολα τα απαραιτητα αρχεια μας εκει (θα μας χρειαστει και για μελλοντικη αναβαθμιση)
Κώδικας: Επιλογή όλων
mkdir ~/codec

και συνεχιζουμε με την Εγκατασταση του Yasm
εκτελοντας τις παρακατω 2 εντολες μια-μια
Κώδικας: Επιλογή όλων
cd ~/codec ; wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz ; tar xzvf yasm-1.2.0.tar.gz ; cd yasm-1.2.0

Κώδικας: Επιλογή όλων
./configure ; make ; sudo checkinstall --pkgname=yasm --pkgversion="1.2.0" --backup=no --deldoc=yes --default


και συνεχιζουμε με την Εγκατασταση του libx264
εκτελοντας τις παρακατω 2 εντολες μια-μια (παραδειγματα κωδικοποιησης για το x264)
Κώδικας: Επιλογή όλων
cd ~/codec ; wget http://download.videolan.org/pub/x264/snapshots/last_x264.tar.bz2 ; tar xjvf last_x264.tar.bz2 ; cd x264-snapshot*

Κώδικας: Επιλογή όλων
./configure --enable-static ; make ; sudo checkinstall --pkgname=x264 --pkgversion="3:$(./version.sh | awk -F'[" ]' '/POINT/{print $4"+git"$5}')" --backup=no --deldoc=yes --fstrans=no --default


και συνεχιζουμε με την Εγκατασταση του libfdk-aac
εκτελοντας τις παρακατω 2 εντολες μια-μια (παραδειγματα κωδικοποιησης για το ACC)
Κώδικας: Επιλογή όλων
cd ~/codec ; wget -O fdk-aac.zip https://github.com/mstorsjo/fdk-aac/zipball/master ; unzip fdk-aac.zip ; cd mstorsjo-fdk-aac*

Κώδικας: Επιλογή όλων
autoreconf -fiv ; ./configure --disable-shared ; make ; sudo checkinstall --pkgname=libfdk-aac --pkgversion="$(date +%Y%m%d%H%M)-git" --backup=no --deldoc=yes --fstrans=no --default


και συνεχιζουμε με την Εγκατασταση του libmp3lame
εκτελοντας
Κώδικας: Επιλογή όλων
cd ; sudo apt-get install libmp3lame-dev


και συνεχιζουμε με την Εγκατασταση του libopus
εκτελοντας τις παρακατω 2 εντολες μια-μια
Κώδικας: Επιλογή όλων
cd ~/codec ; wget http://downloads.xiph.org/releases/opus/opus-1.1.tar.gz ; tar xzvf opus-1.1.tar.gz ; cd opus-1.1

Κώδικας: Επιλογή όλων
./configure --disable-shared ; make ; sudo checkinstall --pkgname=libopus --pkgversion="1.1" --backup=no --deldoc=yes --fstrans=no --default ; make distclean


και συνεχιζουμε με την Εγκατασταση του libvpx
εκτελοντας τις παρακατω 2 εντολες μια-μια (παραδειγματα κωδικοποιησης για το vpx)
Κώδικας: Επιλογή όλων
cd ~/codec ; wget http://webm.googlecode.com/files/libvpx-v1.3.0.tar.bz2 ; tar xjvf libvpx-v1.3.0.tar.bz2 ; cd libvpx-v1.3.0

Κώδικας: Επιλογή όλων
./configure --disable-examples ; make ; sudo checkinstall --pkgname=libvpx --pkgversion='$(echo "1.3.0")' --backup=no --deldoc=yes --fstrans=no --default ; make clean


και συνεχιζουμε με την Εγκατασταση του FFmpeg
εκτελοντας τις παρακατω 2 εντολες μια-μια
Κώδικας: Επιλογή όλων
cd ~/codec ; wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2 ; tar xjvf ffmpeg-snapshot.tar.bz2 ; cd ffmpeg

Κώδικας: Επιλογή όλων
./configure --extra-libs="-ldl" --enable-GPL --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-x11grab ; make ; sudo checkinstall --pkgname=ffmpeg --pkgversion="7:$(date +%Y%m%d%H%M)-git" --backup=no --deldoc=yes --fstrans=no --default ; make distclean ; hash -r

Υπαρχει ενα bug στο forum οπου εμφανιζει τη λεξη "GPL" με κεφαλαια. Δειτε την παρακατω εικονα πως πρεπει να ειναι η παραμετρος της εντολης, και αντικαταστηστε το χειροκινητα με μικρα. :idea:
Εικόνα

και ειμαστε ετοιμοι! :)

Αν θελουμε, μπορουμε να διαγραψουμε τον φακελο codec.

Αναβαθμιση FFmpeg και x264

Για να κανουμε αναβαθμιση, ακολουθουμε την παραπανω διαδικασια απο την αρχη.



Επιπλεον επιλογες

-- Περισσοτερα μπορουμε να δουμε εκτελωντας στο τερματικο
για το FFMPEG
Κώδικας: Επιλογή όλων
man ffmpeg

για το x264
Κώδικας: Επιλογή όλων
x264 --fullhelp


-- Για οποιον χρησιμοποιει το WinFF
μπορει να προσαρμοσει τις νεοτερες εκοδσεις, κανωντας αυτο:
κλεινουμε το WinFF και εκτελουμε
Κώδικας: Επιλογή όλων
cp /usr/share/winff/presets-libavcodec53.xml ~/.winff/presets.xml
sed -i 's/kb /k /g' ~/.winff/presets.xml


μετα απλα ανοιγουμε το WinFF και βλεπουμε τις επιπλεον επιλογες! :thumbup:

-- Περισσοτερα παραδειγματα κωδικοποιησης, μπορουμε να βρουμε εδω https://trac.ffmpeg.org/wiki

Αλλαγες εκδοσεων

x264 revision log
FFmpeg revision log

Τελευταία επεξεργασία από vagrale13 και 10 Αύγ 2014, 16:03, έχει επεξεργασθεί 53 φορά/ες συνολικά
Desktop 1: Mint 13 Maya i386 / Ubuntu 14.10 Utopic Unicorn i386 (development branch)
CPU: AMD ATHLON II X2 215 │ RAM: 4026Mb │ Graphics Card: GeForce 210 512MB │ LG W2243S : 1920 x 1080
Desktop 2: Ubuntu 12.04 LTS Precise Pangoli i386
AMD Athlon 64 X2 5800+ │ 1024Mb │ nForce 7600 256MB (onboard) | 1024 x 768
Laptop : Sony Vaio VGN-N11m : Ubuntu 14.04Lts Trusty Tahr i386 (Mate desktop)


*Οδηγοί - How to - Tutorials σε Κατηγορίες
*Oδηγίες προς νεοεισερχόμενους σε forum ή linux
Άβαταρ μέλους
vagrale13
Freedom
Freedom
 
Δημοσιεύσεις: 7107
Εγγραφή: 04 Απρ 2009, 19:29
Τοποθεσία: κάπου εδώ μέσα στο net :P
Launchpad: vagrale
IRC: vagrale13
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 17 Μαρ 2011, 11:37

Μπράβο, ωραία δουλειά !!!
...μόνο που αντιμετωπίζω ένα πρόβλημα.
Όταν κάνω την αναβάθμιση του ffmpeg ...
και συνεχιζουμε την εγκατασταση με τον παραπανω τροπο, εκτελοντας τις 4 εντολες, απο την εντολη ./configure και τις υπολοιπες

...όταν δίνω την πρώτη εντολή...
Κώδικας: Επιλογή όλων
./configure --enable-GPL --enable-version3 --enable-nonfree --enable-postproc \
    --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
    --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
    --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab

...παίρνω το εξής αποτέλεσμα:
Κώδικας: Επιλογή όλων
rory@rory-VGN-NS31M-S:~/codec/ffmpeg$ ./configure --enable-GPL --enable-version3 --enable-nonfree --enable-postproc \
>     --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab
ERROR: libx264 not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.
rory@rory-VGN-NS31M-S:~/codec/ffmpeg$

...όλα πήγαν μια χαρά μέχρι αυτό το σημείο. Το git μου αναφέρει ότι είναι η τελευταία έκδοση.

Υ.Γ. Ξανά Μπράβο για τον οδηγό !! :-)
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό vagrale13 » 17 Μαρ 2011, 12:35

Για δοκιμασε
Κώδικας: Επιλογή όλων
cd && cd codec
cd ffmpeg
git remote set-url origin git://git.videolan.org/ffmpeg

και μετα διοκιμασε παλι την αναβαθμιση απο την αρχη, και δες αν ειναι ενταξει!
Desktop 1: Mint 13 Maya i386 / Ubuntu 14.10 Utopic Unicorn i386 (development branch)
CPU: AMD ATHLON II X2 215 │ RAM: 4026Mb │ Graphics Card: GeForce 210 512MB │ LG W2243S : 1920 x 1080
Desktop 2: Ubuntu 12.04 LTS Precise Pangoli i386
AMD Athlon 64 X2 5800+ │ 1024Mb │ nForce 7600 256MB (onboard) | 1024 x 768
Laptop : Sony Vaio VGN-N11m : Ubuntu 14.04Lts Trusty Tahr i386 (Mate desktop)


*Οδηγοί - How to - Tutorials σε Κατηγορίες
*Oδηγίες προς νεοεισερχόμενους σε forum ή linux
Άβαταρ μέλους
vagrale13
Freedom
Freedom
 
Δημοσιεύσεις: 7107
Εγγραφή: 04 Απρ 2009, 19:29
Τοποθεσία: κάπου εδώ μέσα στο net :P
Launchpad: vagrale
IRC: vagrale13
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 17 Μαρ 2011, 13:31

Ευχαριστώ !! :thumbup:
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 13 Μάιος 2011, 22:37

Κώδικας: Επιλογή όλων
rory@rory-VGN-NS31M-S:~/codec/x264$ sudo apt-get remove libvpx0 libvpx-dev
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                 
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Το πακέτο libvpx-dev δεν είναι εγκατεστημένο και δεν θα αφαιρεθεί
Μερικά πακέτα είναι αδύνατον να εγκατασταθούν. Αυτό μπορεί να σημαίνει ότι
δημιουργήσατε μια απίθανη κατάσταση ή αν χρησιμοποιείτε την ασταθή
διανομή, ότι μερικά από τα πακέτα δεν έχουν ακόμα δημιουργηθεί ή έχουν
μετακινηθεί από τα εισερχόμενα.
Οι ακόλουθες πληροφορίες ίσως βοηθήσουν στην επίλυση του προβλήματος:

Τα ακόλουθα πακέτα έχουν ανεπίλυτες εξαρτήσεις:
libavcodec52 : Εξαρτάται από: libvpx0 (>= 0.9.0) αλλά δεν πρόκειται να εγκατασταθεί
E: Χαλασμένα πακέτα


...και αυτό...

Κώδικας: Επιλογή όλων
rory@rory-VGN-NS31M-S:~/codec/ffmpeg$ ./configure --enable-GPL --enable-version3 --enable-nonfree --enable-postproc \
>     --enable-libfaac --enable-libmp3lame --enable-libopencore-amrnb \
>     --enable-libopencore-amrwb --enable-libtheora --enable-libvorbis \
>     --enable-libvpx --enable-libx264 --enable-libxvid --enable-x11grab
ERROR: libx264 not found

If you think configure made a mistake, make sure you are using the latest
version from Git.  If the latest version fails, report the problem to the
ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.log" produced by configure as this will help
solving the problem.


...τι γίνεται μ' αυτά; (11.04)
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό vagrale13 » 14 Μάιος 2011, 00:02

@akounadis
Δοκιμασε παλι τον οδηγο και δες αν ειναι τωρα ειναι ενταξει. Ανανεωθηκε! :thumbup:
Desktop 1: Mint 13 Maya i386 / Ubuntu 14.10 Utopic Unicorn i386 (development branch)
CPU: AMD ATHLON II X2 215 │ RAM: 4026Mb │ Graphics Card: GeForce 210 512MB │ LG W2243S : 1920 x 1080
Desktop 2: Ubuntu 12.04 LTS Precise Pangoli i386
AMD Athlon 64 X2 5800+ │ 1024Mb │ nForce 7600 256MB (onboard) | 1024 x 768
Laptop : Sony Vaio VGN-N11m : Ubuntu 14.04Lts Trusty Tahr i386 (Mate desktop)


*Οδηγοί - How to - Tutorials σε Κατηγορίες
*Oδηγίες προς νεοεισερχόμενους σε forum ή linux
Άβαταρ μέλους
vagrale13
Freedom
Freedom
 
Δημοσιεύσεις: 7107
Εγγραφή: 04 Απρ 2009, 19:29
Τοποθεσία: κάπου εδώ μέσα στο net :P
Launchpad: vagrale
IRC: vagrale13
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 14 Μάιος 2011, 09:31

...προσπαθώ να κάνω απεγκατάσταση με την διαδικασία που αναφέρεις για να ξανά κάνω σωστά την εγκατάσταση και μου δίνει αυτό:

Κώδικας: Επιλογή όλων
rory@rory-VGN-NS31M-S:~$ sudo apt-get autoremove x264 ffmpeg qt-faststart build-essential git-core checkinstall \
>   yasm texi2html libfaac-dev libjack-jackd2-dev libmp3lame-dev libsdl1.2-dev \
>   libtheora-dev libva-dev libvdpau-dev libvorbis-dev libvpx libx11-dev libxfixes-dev \
>   libxvidcore-dev zlib1g-dev
[sudo] password for rory:
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                 
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
E: Αδυναμία εντοπισμού του πακέτου qt-faststart
rory@rory-VGN-NS31M-S:~$


...να προχωρήσω στην εγκατάσταση όπως έχει; Τον φάκελο codec τον διέγραψα. Αδυναμία εντοπισμού του πακέτου μου το έδινε και πριν διαγράψω τον φάκελο codec αλλά και μετά.
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό vagrale13 » 14 Μάιος 2011, 11:26

Για δες παλι... τωρα πρεπει να ειναι οκ!
Αλλα, γιατι θελεις να αφαιρεσεις τα πακετα?
Desktop 1: Mint 13 Maya i386 / Ubuntu 14.10 Utopic Unicorn i386 (development branch)
CPU: AMD ATHLON II X2 215 │ RAM: 4026Mb │ Graphics Card: GeForce 210 512MB │ LG W2243S : 1920 x 1080
Desktop 2: Ubuntu 12.04 LTS Precise Pangoli i386
AMD Athlon 64 X2 5800+ │ 1024Mb │ nForce 7600 256MB (onboard) | 1024 x 768
Laptop : Sony Vaio VGN-N11m : Ubuntu 14.04Lts Trusty Tahr i386 (Mate desktop)


*Οδηγοί - How to - Tutorials σε Κατηγορίες
*Oδηγίες προς νεοεισερχόμενους σε forum ή linux
Άβαταρ μέλους
vagrale13
Freedom
Freedom
 
Δημοσιεύσεις: 7107
Εγγραφή: 04 Απρ 2009, 19:29
Τοποθεσία: κάπου εδώ μέσα στο net :P
Launchpad: vagrale
IRC: vagrale13
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 14 Μάιος 2011, 11:29

vagrale13 έγραψε:Για δες παλι... τωρα πρεπει να ειναι οκ!
Αλλα, γιατι θελεις να αφαιρεσεις τα πακετα?


...ok απλά τον φάκελο διέγραψα και πήγα να κάνω απεγκατάσταση για να τα βάλω ξανά απ' την αρχή.
Ξανά προσπαθώ και σου λέω ότι γίνει...
Ευχαριστώ
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Re: Εγκατασταση τελευταιας εκδοσης FFmpeg και x264

Δημοσίευσηαπό akounadis » 14 Μάιος 2011, 11:36

...ξανά το ίδιο...

Κώδικας: Επιλογή όλων
rory@rory-VGN-NS31M-S:~/codec/x264$ sudo apt-get remove libvpx0 libvpx-dev
Ανάγνωση Λιστών Πακέτων... Ολοκληρώθηκε
Κατασκευή Δένδρου Εξαρτήσεων                 
Ανάγνωση περιγραφής της τρέχουσας κατάσταση... Ολοκληρώθηκε
Το πακέτο libvpx-dev δεν είναι εγκατεστημένο και δεν θα αφαιρεθεί
Μερικά πακέτα είναι αδύνατον να εγκατασταθούν. Αυτό μπορεί να σημαίνει ότι
δημιουργήσατε μια απίθανη κατάσταση ή αν χρησιμοποιείτε την ασταθή
διανομή, ότι μερικά από τα πακέτα δεν έχουν ακόμα δημιουργηθεί ή έχουν
μετακινηθεί από τα εισερχόμενα.
Οι ακόλουθες πληροφορίες ίσως βοηθήσουν στην επίλυση του προβλήματος:

Τα ακόλουθα πακέτα έχουν ανεπίλυτες εξαρτήσεις:
libavcodec52 : Εξαρτάται από: libvpx0 (>= 0.9.0) αλλά δεν πρόκειται να εγκατασταθεί
E: Χαλασμένα πακέτα
rory@rory-VGN-NS31M-S:~/codec/x264$
Arch Linux i3, Slackware, Ubuntu Gnome
Intel Core i7-7700HQ CPU @ 2.80GHz ‖ RAM 7617 MiB ‖ Dell Inc. 065C71 - Dell Inc. Inspiron 15 7000 Gaming
Intel Device [8086:591b] {i915} ⋮ nVidia Device [10de:1c8c] {nouveau}
wlp3s0: Intel Wireless 3165 [8086:3165] (rev 79) ⋮ enp2s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Συναντήσεις φίλων του Ubuntu-gr σε πόλεις της Ελλάδας
Άβαταρ μέλους
akounadis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1047
Εγγραφή: 23 Δεκ 2009, 17:40
Τοποθεσία: Πειραιάς
Launchpad: akounadis
Εκτύπωση

Επόμενο

  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Οδηγοί - How to - Tutorials