Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέα

...το μέρος για να ξεκινήσετε!

Συντονιστής: adem1

Κανόνες Δ. Συζήτησης
Παρακαλώ να επιλέξετε, με προσοχή, την άδεια που θέλετε να έχουν οι οδηγοί που συγγράφετε.
Πληροφορίες για τις άδειες μπορείτε να βρείτε εδώ.
Άμα επιθυμείτε κάποια άλλη άδεια επικοινωνήστε με κάποιο Διαχειριστή είτε Συντονιστή.

Σημαντικό είναι να χρησιμοποιήσετε την υπηρεσία http://imagebin.ubuntu-gr.org για τις εικόνες.

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό sotos21 » 12 Νοέμ 2013, 21:44

Off topic:
eliasps έγραψε:Ένα παράδειγμα είναι η τελευταία εγκατάσταση που έκανα στον υπολογιστή, προχθές συγκεκριμένα γιατί χάλασα τα δικαιώματα των χρηστών του συστήματος

Μισό λεπτό γιατί προχτές και εγώ είχα πρόβλημα με τους χρήστες σε 13.10.
Στα καλά καθούμενα ανοίγω το laptop και με έβαζε σε κονσόλα με την παύλα να αναβοσβήνει σε γραμμή που έλεγε root@sotos21(χωρίς να έχω δώσει κάποιο κωδικό, ούτε έχω είσοδο χωρίς κωδικό)
Δίνοντας startx έμπαινα σε συνεδρία root(κανονικά γραφικά) χωρίς δίκτυο.
Δίνοντας service lightdm restart έβγαινα σε οθόνη σύνδεσης αλλά μετά τον κωδικό ήμουνα με llvmpipe (υποβαθμισμένα γραφικά) και χωρίς δίκτυο πάλι.
Έκανα χτες επανεγκατάσταση με τον παραπάνω τρόπο.
Δεν πόσταρα γιατί από την τσαντίλα μου που δεν μπορώ να κάνω εγκατάσταση με mini iso είχα αφαιρέσει ένα σωρό πακέτα όποτε θα με έβριζε ο learner. Βέβαια τα πακέτα τα έχω αφαιρέσει καιρό τώρα, αλλά προχτές μου το παρουσίασε.
Πάντως να πατάς το κουμπί και ενώ περιμένεις να βάλεις κωδικό, να μπαίνεις σαν root με ένα απλό startx ούτε στο backtrack
Τελευταία επεξεργασία από sotos21 και 12 Νοέμ 2013, 22:20, έχει επεξεργασθεί 1 φορά/ες συνολικά
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Καθόλου
2 Ubuntu 19.04 Disco 5.0.0-13 64bit (el_GR.UTF-8, gnome-shell)
3 Intel Core i7-4500U CPU @ 1.80GHz ‖ RAM 15944 MiB ‖ Sony VAIO - SVF1532X1EB
4 Intel Haswell-ULT Integrated Graphics [8086:0a16] {i915} ‖ NVIDIA GK208M [GeForce GT 740M] [10de:1292] {nvidia}
5 wlan0: Broadcom BCM43142 802.11b/g/n [14e4:4365] (rev 01) ⋮ eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
Άβαταρ μέλους
sotos21
Freedom
Freedom
 
Δημοσιεύσεις: 6266
Εγγραφή: 21 Φεβ 2011, 21:28
Τοποθεσία: Αθήνα
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό eliasps » 12 Νοέμ 2013, 22:09

Off topic:
Το πρόβλημα με τα δικαιώματα το συνάντησα αφού έκανα εγκατάσταση το Kali Linux. Είχα κατεβάσει το .iso αρκετό καιρό τώρα για να δω αν περιέχει μία συγκεκριμένη εφαρμογή για το GNOME 2, άσχετη με cracking δικτύων και τα σχετικά που ειδικεύεται η διανομή. Απλά έτυχε να είχα το Kali, είπα να το εγκαταστήσω σε μία κατάτμηση που έχω κενή για τέτοιους λόγους δοκιμών.

Στην εγκατάσταση μου ζήτησε να δημιουργήσω μόνο κωδικό για τον root και όχι για άλλο χρήστη ούτε καν hostname. Οπότε μετά την εγκατάσταση έγινε είσοδος στο Kali ως: root@localhost. Aφού τελικά δεν είχε την εφαρμογή που έψαχνα το κλείνω και πάω να μπω από το Ubuntu για να το διαγράψω.

Εκεί εμφανίστηκε το πρόβλημα. Στην εκκίνηση φορτώνει η plymouth του Ubuntu GNOME και μετά η οθόνη μάυρισε (χωρίς φωτεινότητα, σαν να ήταν κλειστή).
Με Ctrl + Alt + F1 μπήκα στην κονσόλα κανονικά και έκανα login ως elias. Είπα να κάνω sudo apt-get update && sudo apt-get dist-upgrade μπας και... αλλά πήρα «Something wicked happened...». Έδωσα startx και φόρτωσε η επιφάνεια εργασίας χωρίς το GNOME-Shell, η συντόμευση για το τερματικό δεν λειτουργούσε και το άνοιξα αφού πήγα με τον nautilus στο /usr/bin για να κάνω κλικ στο gnome-terminal. Οι εντολές gnome-shell -r και gnome-control-center έδιναν LibGL error loading driver: r600 και segmentation fault . Εκτέλεσα κάτι εντολές για αποκατάσταση των δικαιωμάτων και μετά από επανεκκίνηση υπήρχε πάλι η ίδια συμπεριφορά, μόνο που άνοιγε το GNOME-Shell μετά το startx, αλλά χωρίς ήχο, κάποιες εφαρμογές δεν λειτουργούσαν και άλλα προβλήματα.

Aφού μετά από ψάξιμο δεν έβγαλα άκρη, έκανα επανεγκατάσταση του Ubuntu GNOME και διέγραψα το Kali.
Απέδωσα το πρόβλημα στην εγκατάσταση του Kali, γιατί δεν θυμάμαι να έκανα κάτι άλλο που να μπορούσε να προκαλέσει τέτοιο πρόβλημα.
Δεν άνοιξα θέμα στο forum γιατί με το Kali και τα experimental αποθετήρια που έχω στο Ubuntu, τρέχα γύρευε να βρεις λύση! :P
Άβαταρ μέλους
eliasps
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 4017
Εγγραφή: 16 Δεκ 2011, 22:25
Τοποθεσία: Αθήνα, Αττική
Launchpad: eliasps
IRC: eliasps
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό sotos21 » 12 Νοέμ 2013, 22:26

Off topic:
LibGL error loading driver: r600 είχα και εγώ, γιαυτό άλλωστε έμπαινε ο χρήστης με llvmpipe, αλλά ο root είχε πρόσβαση στον r600!!
Κάτι έγινε με τους drivers και το σύστημα αρχείων. Μήπως έχεις το oibaf ppa;
1 Γνώσεις Linux: Πρώτα βήματα ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Καθόλου
2 Ubuntu 19.04 Disco 5.0.0-13 64bit (el_GR.UTF-8, gnome-shell)
3 Intel Core i7-4500U CPU @ 1.80GHz ‖ RAM 15944 MiB ‖ Sony VAIO - SVF1532X1EB
4 Intel Haswell-ULT Integrated Graphics [8086:0a16] {i915} ‖ NVIDIA GK208M [GeForce GT 740M] [10de:1292] {nvidia}
5 wlan0: Broadcom BCM43142 802.11b/g/n [14e4:4365] (rev 01) ⋮ eth0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
Άβαταρ μέλους
sotos21
Freedom
Freedom
 
Δημοσιεύσεις: 6266
Εγγραφή: 21 Φεβ 2011, 21:28
Τοποθεσία: Αθήνα
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό eliasps » 12 Νοέμ 2013, 22:41

Off topic:
sotos21 έγραψε:LibGL error loading driver: r600 είχα και εγώ, γιαυτό άλλωστε έμπαινε ο χρήστης με llvmpipe, αλλά ο root είχε πρόσβαση στον r600!!
Κάτι έγινε με τους drivers και το σύστημα αρχείων. Μήπως έχεις το oibaf ppa;

Όχι, αλλά με αναζήτηση είδα τι είναι το ppa, μάλλον θα το βάλω, χαχα!
Το πιο «ασταθές» αποθετήριο που έχω είναι το gnome3-staging. Δεν νομίζω να είχα κάποιο σχετικά με οδηγούς στην προηγούμενη εγκατάσταση.
Άβαταρ μέλους
eliasps
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 4017
Εγγραφή: 16 Δεκ 2011, 22:25
Τοποθεσία: Αθήνα, Αττική
Launchpad: eliasps
IRC: eliasps
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό Lionux » 24 Νοέμ 2013, 13:11

Τα συγχαρητηρια μου γι'αυτον τον υπεροχο οδηγο ! Βρηκα το dpkg-repack με το οποιο μπορει καποιος να δημιουργησει deb πακετα απο εγκατεστημενες εφαρμογες κ να τις εγκαταστησει σε καποιο αλλο Ubuntu ιδιας εκδοσης. Αν το κρινετε σχετικο ενσωματωστε το στον οδηγο . Παραθετω καποια σχετικα λινκ :

http://indonetworksecurity.com/linux/ba ... ubuntu.htm

https://apps.ubuntu.com/cat/application ... kg-repack/

http://www.technozones.net/2013/05/tric ... buntu.html
Spoiler: show
System: TOSHIBA Satellite A300
Distro: Ubuntu 14.04.5 trusty
Kernel: 3.13.0-107-generic
Desktop: KDE 4.13.3
Bios: INSYDE version: 2.20
CPU:Dual core Intel T3400
Graphics Card:[AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
Audio Card: Intel 82801
Network Card: Qualcomm Atheros AR928X driver: ath9k
Επιπεδο linux:Μεσο
Aγγλικα:Μετρια
Προγραμματισμος:Oχι
Άβαταρ μέλους
Lionux
punkTUX
punkTUX
 
Δημοσιεύσεις: 173
Εγγραφή: 23 Νοέμ 2009, 02:26
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό eliasps » 25 Νοέμ 2013, 02:22

Lionux έγραψε:Βρηκα το dpkg-repack με το οποιο μπορει καποιος να δημιουργησει deb πακετα απο εγκατεστημενες εφαρμογες κ να τις εγκαταστησει σε καποιο αλλο Ubuntu ιδιας εκδοσης. Αν το κρινετε σχετικο ενσωματωστε το στον οδηγο . Παραθετω καποια σχετικα λινκ :

:thumbup:
Θα διαβάσω σχετικά με την εφαρμογή να δω πως λειτουργεί ακριβώς και θα προσθέσω οδηγίες.
Ευχαριστώ!
Άβαταρ μέλους
eliasps
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 4017
Εγγραφή: 16 Δεκ 2011, 22:25
Τοποθεσία: Αθήνα, Αττική
Launchpad: eliasps
IRC: eliasps
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό MakisM1 » 10 Ιαν 2017, 18:26

Χθες το βραδυ τελειωσα την εγκατασταση της 16.04 στο καινουριο SSD μου.

Ο οδηγος δουλεψε μια χαρα. :clap: Συγχαρητηρια!

Το μυαλο μου δεν... :oops:

Εν ταχει η εμπειρια μου μην την πατησει και αλλος τοσο χαζος οσο ο γραφων.

Κατ'αρχην εκανα καινουρια εγκατασταση με Startup USB, μια χαρα.

Χρησιμοποιωντας τον οδηγο, εκανα λιστα των προγραμματων και την αφησα στην κατατμηση /Home

Μη χρησιμοποιωντας το μυαλο, αντεγραψα το /Home απο την παλια εγκατασταση στην καινουρια. Μετα ακολουθησα τις οδηγιες του οδηγου, επανεγκατεστησα ολα τα πακετα που ειχα στην παλια εγκατασταση και στην διαδικασια επανεγκαταστασης ΕΣΒΗΣΑ ΟΛΑ ΤΑ User Settings απο την παλια εγκατασταση. Οποτε, αντε αλλες δυο ωρες υπομονη να ξανααντιγραψω το /Home :cry:

Προσοχη λοιπον: Πρωτα κανουμε την επανεγκατασταση των πακετων και μετα μεταφερουμε/αντιγραφουμε το /Home

Eliasps συγχαρητηρια για τον οδηγο και τις θερμες μου ευχαριστιες
Γνώσεις ⇛ Linux: Χαμηλο ┃ Προγραμματισμός: Όχι ┃ Αγγλικά: Καλά
Λειτουργικό: Ubuntu 16.04 (English) σε Dell Inspiron 620 | Eγκατασταση Upgrade απο 14.04
Προδιαγραφές ⇛ Intel i5-2320 @ 3GHz │ RAM 16GB │nVidia 1050 │ Μητρικη: Dell 0GDG8Y
WiFi:D-Link System AirPlus G DWL-G122 │ Bluetooth: Γιοκ │ Κάρτα Ήχου: HDA-Intel - HDA Intel PCH│ Αναλυση Οθονης: 3840Χ2160 │ Webcam Logitech C210 USB
Οδηγος για νεοεισερχομενους: http://forum.ubuntu-gr.org/viewtopic.php?f=2&t=279
Άβαταρ μέλους
MakisM1
Επίτιμο μέλος
Επίτιμο μέλος
 
Δημοσιεύσεις: 2784
Εγγραφή: 01 Ιούλ 2009, 11:29
Τοποθεσία: Houston, TX
Εκτύπωση

Re: Επανεγκατάσταση πακέτων παλιάς εγκατάστασης Ubuntu σε νέ

Δημοσίευσηαπό eliasps » 15 Ιαν 2017, 22:41

Να 'σαι καλά Μάκη!

Ετοιμάζω κάποια script που κάνουν τη διαδικασία ευκολότερη, αυτοματοποιημένη. Θα ενημερώσω.
Άβαταρ μέλους
eliasps
antiwinTUX
antiwinTUX
 
Δημοσιεύσεις: 4017
Εγγραφή: 16 Δεκ 2011, 22:25
Τοποθεσία: Αθήνα, Αττική
Launchpad: eliasps
IRC: eliasps
Εκτύπωση

Προηγούμενη

  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Οδηγοί - How to - Tutorials