Πρόβλημα με wireless USB Netgear (WPN111)  Το θέμα επιλύθηκε

...κάρτες δικτύου, modems, προβλήματα internet
Κανόνες Δ. Συζήτησης
Για την ευκολότερη επίλυση του προβλήματός σας.
Καλό είναι να δημοσιεύσετε τα αποτελέσματα των εντολών στο τερματικό :
lspci -nn
lsusb
rfkill list

Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό mark1laz » 09 Φεβ 2012, 02:56

καταρχάς καλησπέρα σας!
έχω ένα pentium 3 στα 800MHZ αλλά δεν έχει επάνω κάρτα δικτύου και έτσι προσπαθώ με ένα USB wireless adapter να μπώ στο internet (WPN111).
εχω δοκιμάσει αρκετές διανομές linux αλλα καμία δεν είναι συμβατή με το usb!
λέω να βάλω ubuntu 10.04 .....θα μπορέσει να δει το usb για να μπαίνω στο internet;;;

ευχαριστώ
1 Linux: Αρχάριος ┃ Προγραμματισμός: C ┃ Αγγλικά: Καλά
2 Ubuntu 10.04.03 LTS
3 Intel Pentium III (Coppermine) 800MHz ‖ RAM 497.3 MiB
4 nVidia Corporation NV11 [GeForce2 MX/MX 400] [10de:0110] (rev b2)
mark1laz
babeTUX
babeTUX
 
Δημοσιεύσεις: 13
Εγγραφή: 09 Φεβ 2012, 02:24
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό the_eye » 09 Φεβ 2012, 03:27

Σου συνιστώ να βάλεις lubuntu 10.04 έχει ποιο ελαφρύ περιβάλλον. Όσο για την κάρτα θέλουμε το hardware id της για να καταλάβουμε σίγουρα αν θα λειτουργεί, αυτό το βλέπεις αν δώσεις στο τερματικό την εντολή
Κώδικας: Επιλογή όλων
lsusb
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο GNU/Linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.15.0-24-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 11251
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό madvinegar » 09 Φεβ 2012, 09:59

Βρες τους windows XP drivers για το usb. Αποσυμπίεσε τους και αντεγραψε τους μεσα σε ενα φακελο καπου στο pc σου.
Μεσα σε αυτους τους drivers υπαρχει καποιο αρχειο με κατάληξη .inf

Πηγαινε μετα μέσω του windows wireless drivers, κανε add+, μετά browse και βρες αυτο το αρχειο με την κατάληξη .inf και επέλεξε το. 99% θα δουλεψει το στικακι.

Εχω της Netgear ενα usb στικακι για wifi και μια pcmci card για wifi και δουλευουν τελεια και τα δυο με τον παραπανω τροπο που σου ειπα. Η netgear ειναι αρκετα συμβατη με διανομες linux απ'ότι εχω καταλάβει.
1 Γνώσεις Linux: Μέτριο ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Πολύ Καλό
2 Ubuntu 18.04 bionic beaver 4.13.0-16-generic 64bit (el_GR.UTF-8, Gnome ubuntu)
3 Intel Core2 Duo CPU T5550 1.83GHz ‖ RAM 2008 MiB ‖ Acer Chapala - Acer, inc. Aspire 5920G
4 Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470] [1002:95c4] {radeon}
5 wlan0: Intel PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02) ⋮ eth0: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
Blog: https://madvinegar.wordpress.com/
Άβαταρ μέλους
madvinegar
superbTUX
superbTUX
 
Δημοσιεύσεις: 3105
Εγγραφή: 15 Ιαν 2012, 21:10
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό mark1laz » 09 Φεβ 2012, 17:43

η lsusb εμφάνισε:
Κώδικας: Επιλογή όλων
konstantinos@desktop-pc:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 1385:5f01 Netgear, Inc WPN111 (no firmware)
Bus 002 Device 003: ID 062a:0102 Creative Labs
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


και η lspci -nn

Κώδικας: Επιλογή όλων
konstantinos@desktop-pc:~$ lspci -nn
00:00.0 Host bridge [0600]: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] [1106:0691] (rev c4)
00:01.0 PCI bridge [0604]: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP] [1106:8598]
00:07.0 ISA bridge [0601]: VIA Technologies, Inc. VT82C686 [Apollo Super South] [1106:0686] (rev 40)
00:07.1 IDE interface [0101]: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE [1106:0571] (rev 06)
00:07.2 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 1a)
00:07.3 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 1a)
00:07.4 Host bridge [0600]: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] [1106:3057] (rev 40)
00:07.5 Multimedia audio controller [0401]: VIA Technologies, Inc. VT82C686 AC97 Audio Controller [1106:3058] (rev 50)
00:08.0 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 62)
00:08.1 USB Controller [0c03]: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller [1106:3038] (rev 62)
00:08.2 USB Controller [0c03]: VIA Technologies, Inc. USB 2.0 [1106:3104] (rev 65)
00:0b.0 Multimedia audio controller [0401]: Creative Labs SB Live! EMU10k1 [1102:0002] (rev 07)
00:0b.1 Input device controller [0980]: Creative Labs SB Live! Game Port [1102:7002] (rev 07)
01:00.0 VGA compatible controller [0300]: nVidia Corporation NV11 [GeForce2 MX/MX 400] [10de:0110] (rev b2)


φίλε madvinegar τους windows XP drivers για το usb τους εχω αλλα μήπως πρεπει να βάλω πρωτα το ndiswrapper;;;
1 Linux: Αρχάριος ┃ Προγραμματισμός: C ┃ Αγγλικά: Καλά
2 Ubuntu 10.04.03 LTS
3 Intel Pentium III (Coppermine) 800MHz ‖ RAM 497.3 MiB
4 nVidia Corporation NV11 [GeForce2 MX/MX 400] [10de:0110] (rev b2)
mark1laz
babeTUX
babeTUX
 
Δημοσιεύσεις: 13
Εγγραφή: 09 Φεβ 2012, 02:24
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό the_eye » 09 Φεβ 2012, 18:19

Το ndiswrapper δημιουργεί προβλήματα.

Να η κάρτα σου και από ότι φαίνεται λείπει το firmware.
Κώδικας: Επιλογή όλων
Βus 002 Device 004: ID 1385:5f01 Netgear, Inc WPN111 (no firmware)


Αν τρέξεις το
Κώδικας: Επιλογή όλων
jockey-gtk

σου βγάζει κάτι ;

Ρώτα και τον logari81 γιατί εδώ βγάλανε κάποια άκρη.
viewtopic.php?f=39&t=15722
Όσο λιγότερο κλειστό λογισμικό έχεις, τόσα λιγότερα προβλήματα στο GNU/Linux.
1 Γνώσεις ⇛ Linux: Καλό ┃ Προγραμματισμός: Ναι PHP, MySQL ┃ Αγγλικά: Καλά
2 Ubuntu 16.04 xenial 4.15.0-24-generic 64bit (el_GR.UTF-8, GNOME-Flashback:Unity gnome-flashback-compiz)
3 Intel Core i3-6100 CPU @ 3.70GHz ‖ RAM 3832 MiB ‖ Gigabyte B150M-HD3 DDR3-CF
4 Intel Sky Lake Integrated Graphics [8086:1912] {i915_bpo}
5 enp1s0: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
Οδηγοί Ubuntu Βίντεο Οδηγοί
Άβαταρ μέλους
the_eye
Διαχειριστής
Διαχειριστής
 
Δημοσιεύσεις: 11251
Εγγραφή: 16 Μαρ 2010, 17:19
Launchpad: ntoulasd
IRC: the_eye_
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό madvinegar » 09 Φεβ 2012, 19:50

mark1laz έγραψε:φίλε madvinegar τους windows XP drivers για το usb τους εχω αλλα μήπως πρεπει να βάλω πρωτα το ndiswrapper;;;


Εγω το ξερω ως windows wireless drivers, γι' αυτο το ανεφερα ετσι.

Ο σιγουρα πιο ενημερωμενος the_eye λεει πως προκαλει προβληματα, αλλα εγω οπως ειπα το εχω ετσι σε 2 υπολογιστες εδω και παραπολυ καιρο και δουλευουνε ρολοι.
Αν θελεις δοκιμαζεις.
Τελευταία επεξεργασία από madvinegar και 09 Φεβ 2012, 23:13, έχει επεξεργασθεί 1 φορά/ες συνολικά
1 Γνώσεις Linux: Μέτριο ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Πολύ Καλό
2 Ubuntu 18.04 bionic beaver 4.13.0-16-generic 64bit (el_GR.UTF-8, Gnome ubuntu)
3 Intel Core2 Duo CPU T5550 1.83GHz ‖ RAM 2008 MiB ‖ Acer Chapala - Acer, inc. Aspire 5920G
4 Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470] [1002:95c4] {radeon}
5 wlan0: Intel PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02) ⋮ eth0: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
Blog: https://madvinegar.wordpress.com/
Άβαταρ μέλους
madvinegar
superbTUX
superbTUX
 
Δημοσιεύσεις: 3105
Εγγραφή: 15 Ιαν 2012, 21:10
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό medigeek » 09 Φεβ 2012, 19:58

Η λύση είναι εδώ:
viewtopic.php?p=158112#p158112
viewtopic.php?p=158200#p158200
https://launchpad.net/~logari81/+archive/ppa

Κι εδώ υπάρχει μια συζήτηση στα αγγλικά: http://ubuntuforums.org/showthread.php?t=1012812

1. Ποια έκδοση ubuntu έχεις τώρα;
2. Εννοούσες ότι θέλεις να εγκαταστήσεις το ubuntu 10.04 ή το 11.04;
Κύπριος; Κόπιασε στο ubuntu-cy! ┃ Launchpad Debian Github
Οδηγός για νεοεισερχόμενους -- Αρχικές οδηγίες για αρχάριους χρήστες του Ubuntu

1 Γνώσεις Linux: Πολύ καλό ┃ Προγραμματισμού: Πολύ καλό ┃ Αγγλικών: Πολύ καλό
2 Ubuntu 12.10 quantal 3.5.0-21-generic 64bit (en_US.UTF-8, GNOME cinnamon2d), Ubuntu 3.5.0-19-generic, Windows 7
3 Intel Core2 Duo CPU E6550 2.33GHz ‖ RAM 5970 MiB ‖ MSI MS-7235
4 nVidia G73 [GeForce 7300 GT] [10de:0393] {nvidia}
5 eth0: Realtek RTL-8110SC/8169SC Gigabit Ethernet [10ec:8167] (rev 10)
Άβαταρ μέλους
medigeek
Freedom
Freedom
 
Δημοσιεύσεις: 5023
Εγγραφή: 24 Μάιος 2008, 14:49
Τοποθεσία: Σερβία/Κύπρος
Launchpad: medigeek
IRC: savvas
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό dim459 » 09 Φεβ 2012, 21:47

@madvinegar
Χωρίς πρόθεση να το παίξω δάσκαλος (δεν έχω τις κατάλληλες γνώσεις άλλωστε), επειδή έχω την εντύπωση ότι το έχεις ξαναπροτείνει σε ανάλογη περίπτωση, ισχύει αυτό που σου έγραψε ο the_eye.
Το ndiswrapper προτείνεται μόνο σαν έσχατη λύση και αν δεν δούλεψε οτιδήποτε άλλο.
Γνώσεις ⇛ Linux: Αν μου δώσεις οδηγίες σε τερματικό δεν τρομάζω ┃ Προγραμματισμός: Καθόλου┃ Αγγλικά: Εξαιρετικά
Λειτουργικό : Πάντα την τρέχουσα έκδοση ubuntu/kubuntu 64bit και σε κάποια pc 12.04 32bit
Συσκευές-> Πάρα πολλές, θα στο γράψω ανά περίπτωση.
Άβαταρ μέλους
dim459
superbTUX
superbTUX
 
Δημοσιεύσεις: 3653
Εγγραφή: 15 Φεβ 2009, 19:28
Τοποθεσία: Bόρεια Αττική
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό mangelasakis » 09 Φεβ 2012, 22:32

dim459 έγραψε:@madvinegar
Χωρίς πρόθεση να το παίξω δάσκαλος (δεν έχω τις κατάλληλες γνώσεις άλλωστε), επειδή έχω την εντύπωση ότι το έχεις ξαναπροτείνει σε ανάλογη περίπτωση, ισχύει αυτό που σου έγραψε ο the_eye.
Το ndiswrapper προτείνεται μόνο σαν έσχατη λύση και αν δεν δούλεψε οτιδήποτε άλλο.

Μπορώ να το επιβεβαιώσω και εγώ ότι το ndiswrapper στις περισσότερες περιπτώσεις δημιουργεί περισσότερα προβλήματα... Δυστυχώς είναι ορισμένοι που νομίζουν ότι είναι πιο εύκολο και εξίσου αποτελεσματικό να βρεις τους drivers από τα windows και να τους εγκαταστήσεις με το ndiswrapper. Αυτό όμως δεν είναι σωστό και στις περισσότερες περιπτώσεις δημιουργεί πολύ περισσότερα προβλήματα που είναι και πιο δύσκολο να διορθωθούν... Την είχα πατήσει και εγώ έτσι παλιότερα που δεν είχα καθόλου πείρα και γνώσεις και το ίδιο έκανε και ένας φίλος μου που νόμιζε ότι όλα λύνονται με τους drivers των windows.. Ευτυχώς εδώ δεν είναι windows αλλά linux και το καλύτερο πράγμα που έχετε να κάνετε είναι να ψάξετε στο google και να ρωτήσετε εδώ για περαιτέρω βοήθεια καθώς και επίσης να ενημερώσετε στο launchpad αν διαπιστώσετε κάποιο πρόβλημα ώστε να βρεθεί μόνιμη και όχι προσωρινή λύση στο πρόβλημα σας... Ξαναλέω να σκέφτεστε με τον τρόπο του linux και όχι με τον τρόπο των windows. Ξεχάστε τα windows...
Spoiler: show
Linux: 5ετής χρήση ┃ Προγραμ: μόνο C προς το παρών ┃ Αγγλικά: Μέτριος προς καλός
Desktop:
Ubuntu gnome 14.04 amd64 - Debian testing amd64
CPU: 4x AMD Phenom II X4 955 ‖ RAM 8000 MiB ‖ Gigabyte GA-MA785GT-UD3H
[Radeon HD 4200] Radeon HD 7750 ⎨1002:9710⎬
RTL8111/8168B PCI ⎨10ec:8168⎬ (rev 02)
Laptop:
Ubuntu gnome 14.04 amd64
4x Intel Core i3 M 330 2.13GHz ‖ RAM 3628 MiB ‖ Sony Corporation VPCEB1J1E
Intel VGA [8086:0046] (rev 02)
eth0: [11ab:4381] (rev 11) ⋮ wlan0: AR9285 [168c:002b] (rev 01)
mangelasakis
daemonTUX
daemonTUX
 
Δημοσιεύσεις: 1149
Εγγραφή: 10 Μαρ 2009, 06:08
Εκτύπωση

Re: Πρόβλημα με wireless USB Netgear (WPN111)

Δημοσίευσηαπό madvinegar » 09 Φεβ 2012, 23:12

Παιδιά εννοειται, ουτε εγω το παιζω δάσκαλος, αντιθετως ειμαι ακομα στην αρχη.

Απλά προτεινα μια μονιμη λυση που εχει δουλεψει αψογα (τουλαχιστον σε εμενα) σε δυο υπολογιστες. Μακάρι να λυθει το θέμα αμιγως με linux.
Φυσικά και σκεφτομαι με την νοοτροπία linux αλλά βασικα το θεμα ειναι να το κανουμε να δουλεψει ωστε να κανει ο ανθρωπος τη δουλεια του. Λετε να τον νοιαζει αν το εκανε μεσω των XP drivers ή μεσω firmware? (Μιλαω παντα για μονιμη και σωστη λυση οπως αποδειχτηκε τουλαχιστον σε εμενα). Και μαλιστα οσον αφορα την pcmci καρτα μου, τo goolαρα πρωτα και μου εβγαλε αυτη τη λυση σε σχεδον ολα τα φορουμ. Και το γεγονος οτι το προτεινω σημαίνει πως οτι εμενα μου εχει δουλεψει αψογα. Λετε αν ειχα προβληματα να το προτεινα σε αλλον?

Τεσπα, μια παρεα ειμαστε και βοηθαμε ο ενας τον αλλο. Ειπα να πω την ιδέα μου απλα να υπαρχει. Συγνωμη αν δημιουργησα καποιο προβλημα.
1 Γνώσεις Linux: Μέτριο ┃ Προγραμματισμού: Καθόλου ┃ Αγγλικών: Πολύ Καλό
2 Ubuntu 18.04 bionic beaver 4.13.0-16-generic 64bit (el_GR.UTF-8, Gnome ubuntu)
3 Intel Core2 Duo CPU T5550 1.83GHz ‖ RAM 2008 MiB ‖ Acer Chapala - Acer, inc. Aspire 5920G
4 Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470] [1002:95c4] {radeon}
5 wlan0: Intel PRO/Wireless 3945ABG [Golan] Network Connection [8086:4222] (rev 02) ⋮ eth0: Broadcom NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
Blog: https://madvinegar.wordpress.com/
Άβαταρ μέλους
madvinegar
superbTUX
superbTUX
 
Δημοσιεύσεις: 3105
Εγγραφή: 15 Ιαν 2012, 21:10
Εκτύπωση

Επόμενο

  • ΣΧΕΤΙΚΑ ΘΕΜΑΤΑ
    ΑΠΑΝΤΗΣΕΙΣ
    ΠΡΟΒΟΛΕΣ
    ΣΥΓΓΡΑΦΕΑΣ

Επιστροφή στο Κάρτες Δικτύου (Ethernet, WiFi, Bluetooth) / Internet